hdu 4734 【数位DP】

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6391    Accepted Submission(s): 2461


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
题意理解:要求在不大于B的区间内找到不大于 F(A)的个数有多少个。

解题思路:这道题是一个数位DP的题,关键在于找到状态转移的条件。我们用dp[pos][sum]来保存结果,pos代表的是当前的位置,sum表示当前的依照F()的公式的和是多少,dp[pos][sum]即表示:长度为pos且权值不大于sum的数的个数。这样就可以让每个数所求的个数,是每个数的固有性质,不再需要每次查询都去memset(dp,-1,sizeof(dp)),如果每次都去memset,那必然超时,只需要一次就够了。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[20];
int dp[20][100010];
int totol;
int dfs(int pos,int sum,int limit)
{
    if(pos==-1)
    {
        if(totol<sum)
            return 0;
        else
            return 1;
    }
    if(totol<sum)
        return 0;
    if(!limit&&dp[pos][totol-sum]!=-1)
        return dp[pos][totol-sum];
    int n=limit?a[pos]:9;
    int ans=0;
    for(int i=0;i<=n;i++)
    {
        ans+=dfs(pos-1,sum+i*(1<<pos),limit&&a[pos]==i);
    }
    if(!limit)
        dp[pos][totol-sum]=ans;
    return ans;
}
int  f(int x)
{
    int temp=1;
    int sum=0;
    while(x)
    {
       sum+=(x%10)*temp;
       temp*=2;
       x/=10;
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    int k=1;
     memset(dp,-1,sizeof(dp));
    while(t--)
    {
       
        int A,B;
        scanf("%d%d",&A,&B);
        totol=f(A);
        int cnt=0;
        while(B)
        {
            a[cnt]=B%10;
            cnt++;
            B/=10;
        }
        printf("Case #%d: %d\n",k,dfs(cnt-1,0,1));
        k++;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值