2017 Multi-University Training Contest - Team 1 1011 KazaQ's Socks

Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k -th day.
 

Input
The input consists of multiple test cases. (about 2000 )

For each case, there is a line contains two numbers n,k (2n109,1k1018) .
 

Output
For each test case, output "Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2
题意: 给定一个 n,k (2n109,1k1018) 一个人有n双袜子, 编号1-n, 每天早上穿衣柜里编号最下的一双, 晚上放到洗衣篮里, 当衣柜里只有
一双袜子的时就将之前的袜子洗掉, 并在第二天晚上放回衣柜里, 问第k天穿的是第几双袜子。
思路, 找规律的签到题, 举个例子 n=5时 穿袜子的规律就是 1 2 3 4 5   1 2 3 4    1 2 3 5  1 2 3 4   1 2 3 5
可以看出, 前n天不用管, 之后每n-1天就是循环节, 每一个循环节 前n-2天不变, 之后第n-1天跟循环的奇偶有关


#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
typedef long long LL;

LL n, k;
int main(){
    int Case = 0;
    while(~scanf("%lld %lld", &n, &k)){
        printf("Case #%d: ", ++Case);
        if(k <= n) printf("%lld\n", k);
        else{
            k -= n;
            LL cnt = k / (n - 1);
            if(k % (n - 1)) cnt++;
            k -= (n - 1) * (cnt - 1);
            if(k != n - 1) printf("%lld\n", k);
            else {
                if(cnt & 1) printf("%lld\n", n - 1);
                else printf("%lld\n", n);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值