1438 [CA1002]Circle

Description

Given a circle with radius R, please calculate the area of this circle.

Input

The input contains a real number R(0.1 <= R <= 100)

Output

Output the area of the circle in a line. The answer should be rounded to 8 digits after the decimal point.

Sample Input

0.564189583547

Sample Output

1.00000000

Hint

you can assume PI = 3.14159265358979

Submission

answer.cpp

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
    double R;
    cin>>R;
    cout<<setprecision(8)<<fixed<<3.14159265358979*R*R<<endl;
    return 0;
}

Standard Answer

answer.cpp

#include <iostream>
#include <iomanip>

using namespace std;

const double PI = 3.14159265358979;

int main()
{
    double r; cin >> r;
    cout << fixed << setprecision(8) << r * r * PI << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值