1638 function overloading

Description

写出3组Plus函数的声明与实现,类型分别为int,double,string

Sample Input

1
2 3
2.5 3.5
women day

Sample Output

5
6
womenday

Provided Codes

overload.cpp

#include<iostream>
#include"overlode.h"
int main() {
    int n;
    int a,b;
    double c,d;
    std::string str1,str2;
    std::cin>>n;
    while(n--) {
        std::cin>>a >> b ;
        std::cin>>c >> d;
        std::cin >> str1 >>str2;
        std::cout <<myplus(a, b) << endl;
        std::cout <<myplus(d, c) << endl;
        std::cout <<myplus(str1, str2) << endl;
    } 
    return 0;
}

Submission

overload.h

#include<string>
#include<stdio.h>
using namespace std;
int myplus(int a,int b){
    return a+b;
}

double myplus(double a,double b){
    return a+b;
}

string myplus(string a,string b){
    return a+b;
}

Standard Answer

overload.h

#include<iostream>
using namespace std;
int myplus(int a, int b);
double myplus(double a, double b);
string myplus(string a, string b);
int myplus(int a, int b){
    return a+b;
}
double myplus(double a, double b){
    return a+b;
}
string myplus(string a, const string b) {
    return a+b;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值