hdu4709-(三角形-叉乘)

Herding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3319    Accepted Submission(s): 988


Problem Description
Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.
 

Input
The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case.
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.
 

Output
For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.
 

Sample Input
 
 
1 4 -1.00 0.00 0.00 -3.00 2.00 0.00 2.00 2.00
 

Sample Output
 
 
2.00

这道题目其实挺简单的,读完题目之后就应该想到求的是三角形的最小面积,

在操作时由于数据小,三层循环,就可以解决,三角形的面积可以用叉积来得到

叉乘法:行列式

                |    x1   y1    1     |

S= 0.5* |    x2    y2    1    |

                |    x3    y3    1    |

三阶行列式:  S=  0.5×(    x1y2    -    x1y3    -    x2y1    +    x3y1    +    x2y3    -    x3y2    )

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int T; cin>>T;
    while(T--){
        int n;  double s=-1,minz=9999999,a[105],b[105];  cin>>n;
        for(int i=1;i<=n;i++) scanf("%lf%lf",&a[i],&b[i]);
        if(n<=2){
            printf("Impossible\n");
            continue;
        }
        for(int i=1;i<=n-2;i++)
            for(int j=i+1;j<=n-1;j++){
                for(int k=j+1;k<=n;k++){
                    s=fabs(a[i]*b[j]-a[j]*b[i]+a[k]*b[i]-a[i]*b[k]+a[j]*b[k]-a[k]*b[j])*(0.5);
                    if(s!=0&&s<minz)
                        minz=s;
                }
            }
        if(minz==9999999)
            printf("Impossible\n");
        else
        printf("%.2lf\n",minz);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值