数据结构学习第一课

作为一个工业设计同学,自觉技术不够,于是在网易云课堂开始了我的数据结构学习。这,就是一切的开始。


第一课总是比较简单的,但是有一道编程练习却难倒了我。这是一道PAT题,我绞尽脑汁都无法做到全对,所以只能求助于网络了,当然我也得到了一份大神的答案。现在就让我来解析一下吧。


原题:

01-2. Maximum Subsequence Sum (25)


Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
代码

#include <stdio.h>
#include <stdlib.h>


int main()
{
int k;
int *data;
int i;


int start, end, sum, temp, tempi, tempj;


while (scanf("%d", &k) != EOF)
{
data = (int *)malloc(k * sizeof(int));
for (i = 0; i < k; i++)
{
scanf("%d", &data[i]);
}
sum = 0;
start = 0;
end = k - 1;
temp = 0;
tempi = 0;
tempj = 0;
for (i = 0; i < k; i++)
{
if (temp >= 0)
{
temp += data[i];
tempj = i;
}
else
{
temp = data[i];
tempi = i;
tempj = i;
}
if (temp > sum || (temp == 0 && end == k - 1))//temp确实比sum大, 或者, sum依然是初始状态(end == k-1即表示)而且temp==0, 需要替换
{
sum = temp;
start = tempi;
end = tempj;
}
}
printf("%d %d %d\n", sum, data[start], data[end]);
}
return 0;
}


首先是在我看来非常大神的一招,那就是用malloc分配内存的一招,估计连指针都不会用的我暂时是学不会了T_T

上面这段代码的主要思想是用“在线处理”的方法找到最大子列的和值,在寻找的过程中用temp记录下当前子列的和值、起始以及终止,再通过一个判断来决定是否把当前temp中的起始和终止赋值给最终的答案。其中最为巧妙的地方就是这个判断了,让我来仔细解读一下:

判断的前半部分比较好理解,当当前子列的和值大于储存的和值时,进行替换。后半部分就比较费解了,我的理解是,后半部分的判断是为了防止一串0后面跟了一个负数的情况产生错误的。

对于start、end的初始设置又有效地解决了全是负数的情况,所以这段代码可谓是巧妙,是现阶段的我需要崇拜的!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值