[最大权森林] [POJ] 3723 Conscription

Conscription

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17473 Accepted: 6058

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

 

森林->树的集合

问题转化至求权最大森林

用克鲁斯卡尔解决

 

/*
	Zeolim - An AC a day keeps the bug away
*/

//#pragma GCC optimize(2)
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cmath>
#include <cctype>
#include <string>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <set>
#include <sstream>
#include <map>
#include <ctime>
#include <vector>
#include <fstream>
#include <list>
#include <iomanip>
#include <numeric>
using namespace std;
typedef long long ll;

const int MAXN = 5e4 + 100;

int n, m, k;

struct edge
{
	int from, to, val;
}arr[MAXN];

int fa[MAXN] = {0};

int findfa(int x)
{
	return x == fa[x] ? x : fa[x] = findfa(fa[x]);
}

bool cmp(edge a, edge b)
{
	return a.val > b.val;
}

int skrskr()
{
	int ret = 0;

	for(int i = 0; i <= n + m; i++)
		fa[i] = i;

	sort(arr, arr + k, cmp);

	for(int i = 0; i < k; i++)
	{
		int p = findfa(arr[i].from), q = findfa(arr[i].to);
		if(p != q)
		{
			fa[p] = q;
			ret += arr[i].val;
		}
	}

	return ret;
}

int main()
{
    //ios::sync_with_stdio(false);
    //cin.tie(0);     cout.tie(0);
    //freopen("D://test.in", "r", stdin);
    //freopen("D://test.out", "w", stdout);

	int r;

	scanf("%d", &r);

	while(r--)
	{
		scanf("%d%d%d", &n, &m, &k);
		
		for(int i = 0; i < k; i++)
		{
			scanf("%d%d%d", &arr[i].from, &arr[i].to, &arr[i].val);
			arr[i].to += n;
		}

		int ans = (n + m) * 10000 - skrskr();

		printf("%d\n", ans);
	}
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值