[POJ 1125]Stockbroker Grapevine[dijkstra]

Stockbroker Grapevine

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37174 Accepted: 20685

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001

题意

已知一群人以及这群人中谣言在某两个人之间传播的单向时间。让你选择一个人作为起点,使得谣言传播遍所有人的所需时间最短。

题解

先考虑求谣言从某一起点开始传遍所有人的时间,很明显的最短路问题,跑一遍最短路,所有点中dis的最大值就是传遍的时间。再考虑这个时间的最小值,注意到N的范围最大只有100,于是我们可以直接枚举每一个点,将其作为起点跑一边最短路即可。

#include <cstdio>
#include <queue>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAX_V = 210;
struct edge{
  int to, cost;
  edge(int _to, int _cost): to(_to), cost(_cost){}
};
vector<edge> G[MAX_V];
int dis[MAX_V];
void init()
{
  for(int i = 0; i < MAX_V; i++)
    G[i].clear();
}
void addedge(int u,int v,int w)
{
  G[u].push_back(edge(v, w));
}
void dijkstra(int s)
{
  priority_queue<pair<int, int> > que;
  memset(dis, 0x3f, sizeof dis);
  dis[s] = 0;
  que.push(make_pair(0, s));
  while(!que.empty())
  {
    int x = que.top().second; que.pop();
    for(int i = 0; i < G[x].size(); i++)
    {
      int v = G[x][i].to, cost = G[x][i].cost;
      if(dis[v] > dis[x] + cost)
      {
        dis[v] = dis[x] + cost;
        que.push(make_pair(-dis[v], v));
      }
    }
  }
}
int main()
{
  int N;
  while(cin >> N)
  {
    if(N == 0)  break;
    init();
    for(int i = 1; i <= N; i++)
    {
      int tot, v, w;
      cin >> tot;
      for(int j = 1; j <= tot; j++)
      {
        cin >> v >> w;
        addedge(i, v, w);
      }
    }
    int ansi = N + 1, ansdis = 0x3f3f3f3f;
    for(int i = 1; i <= N; i++)
    {
      dijkstra(i);
      int temp = 0;
      for(int j = 1; j <= N; j++)
      {
        temp = max(temp, dis[j]);
    //    cout << dis[j] << " " ;
      }
    //  cout << endl;
      if(ansdis > temp)
      {
        ansdis = temp;
        ansi = i;
      }
    }
    if(ansdis == 0x3f3f3f3f)  cout << "disjoint" << endl;
    else  cout << ansi << " " << ansdis << endl;
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值