分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
输入格式:
第一行输入M与N的值。(1 <= M <=100000, 1 <= N <= 100000)
第二行依次输入M个有序的整数。
第三行依次输入N个有序的整数。
输出格式:
输出合并后的单链表所包含的M+N个有序的整数。
样例">输入样例:
6 5
1 23 26 45 66 99
14 21 28 50 100
输出样例:
1 14 21 23 26 28 45 50 66 99 100
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(int n);
void display(struct node *head);
void listmerge(struct node *head1,struct node *head2);
int main()
{
struct node *head1,*head2;
int m,n;
scanf("%d%d",&m,&n);
head1=creat(m);
head2=creat(n);
listmerge(head1,head2);
display(head1);
return 0;
}
struct node *creat(int n)
{
struct node *head,*p,*tail;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return (head);
}
void display(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
printf("%d%c",p->data,p->next ? ' ' : '\n');
p=p->next;
}
}
void listmerge(struct node *head1,struct node *head2)
{
struct node *p1,*p2,*tail;
p1=head1->next;
p2=head2->next;
head1->next=NULL;
tail=head1;
free(head2);
while(p1&&p2)
{
if(p1->data<=p2->data)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
}
if(p1)
tail->next=p1;
else
tail->next=p2;
}