nyoj267郁闷的c小加 中缀表达式转后缀求值

题目:

郁闷的C小加(二)

时间限制:1000 ms | 内存限制:65535 KB

难度:4

描述

聪明的你帮助C小加解决了中缀表达式到后缀表达式的转换(详情请参考“郁闷的C小加(一)”),C小加很高兴。但C小加是个爱思考的人,他又想通过这种方法计算一个表达式的值。即先把表达式转换为后缀表达式,再求值。这时又要考虑操作数是小数和多位数的情况。

输入

第一行输入一个整数T,共有T组测试数据(T<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个运算式,每个运算式都是以“=”结束。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数并且小于1000000。
数据保证除数不会为0。

输出

对于每组测试数据输出结果包括两行,先输出转换后的后缀表达式,再输出计算结果,结果保留两位小数。两组测试数据之间用一个空行隔开。

样例输入

2
1+2=
(19+21)*3-4/5=

样例输出

12+=
3.00

1921+3*45/-=
119.20

来源

改编自NYOJ

上传者

xiewuqiang

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<cctype>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 1234;
int T,n,m;
int ranks[maxn];//优先级
char b[maxn];//存后缀表达式

void init()
{
    ranks['=']=-1;
    ranks['(']=0;
    ranks['+']=ranks['-']=1;
    ranks['*']=ranks['/']=2;
    ranks[')']=3;
}

double cal(char ch,double x,double y)
{
    if(ch=='+')
        return x+y;
    else if(ch=='-')
        return x-y;
    else if(ch=='*')
        return x*y;
    else
        return x/y;

}

void change(char a[])//中缀转后缀
{
    stack<char>st;
    int j=0;
    int  len=strlen(a);
    st.push('=');//现将=压进栈为了之后的运算符好比较优先级
    for(int i=0;a[i]!='=';i++)
    {
        if(isdigit(a[i])||a[i]=='.')//小数情况
            b[j++]=a[i];
        else
        {
            b[j++]='#';//分割运算数
            if(a[i]=='(')
                st.push(a[i]);
            else if(a[i]==')')
            {
                while(st.top()!='(')
                {
                    b[j++]=st.top();
                    st.pop();
                }
                st.pop();
            }
            else
            {
                while(ranks[a[i]]<=ranks[st.top()])//把优先级大于他的都出栈
                {
                    b[j++]=st.top();
                    st.pop();
                }
                st.push(a[i]);
            }
        }
    }
    while(!st.empty())//最后清空栈
    {
        b[j++]=st.top();
        st.pop();
    }
    b[j]='\0';
}

double calculate()//后缀表达式的计算
{
    char c[maxn];
    int j=0;
    stack<double>st;
    for(int i=0;b[i]!='=';i++)
    {
        if(isdigit(b[i])||b[i]=='.')
            c[j++]=b[i];
        else
        {
            if(j!=0)
            {
                st.push(atof(c));//字符串转数字函数的运用
                memset(c,'\0',sizeof(c));
                j=0;
            }
            if(b[i]!='#')
            {
                double n1,n2;
                n1=st.top();
                st.pop();
                n2=st.top();
                st.pop();
                st.push(cal(b[i],n2,n1));//运算并入栈
            }
        }
    }
    return st.top();
}

int main()
{
    init();
    char s[maxn];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        change(s);
        for(int i=0;i<strlen(b);i++)
            if(b[i]!='#')
                printf("%c",b[i]);
        printf("\n");
        printf("%.2f\n",calculate());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值