2018 Multi-University Training Contest 1(HDU 6299)

Balanced Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2595    Accepted Submission(s): 650


 

Problem Description

Chiaki has n strings s1,s2,…,sn consisting of '(' and ')'. A string of this type is said to be balanced:

+ if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.

Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤105) -- the number of strings.
Each of the next n lines contains a string si (1≤|si|≤105) consisting of `(' and `)'.
It is guaranteed that the sum of all |si| does not exceeds 5×106.

 

 

Output

For each test case, output an integer denoting the answer.

 

 

Sample Input

 

2

1

)()(()(

2

) )(

 

 

Sample Output

 

4

2

 

 

Source

2018 Multi-University Training Contest 1

 

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6308 6307 6306 6305 6304 

 

题解:题目要求是求出怎样排序字符串将他们合在一起形成完整括号的数目最大。首先在输入字符串的同时先将其中已经形成完整括号的字符删掉。

在整合完后会发现字符串会有

)))(((((

)))))(((

)))))))))

(((((((((

这四种情况,将他们总结一下可以写出四个式子。要尽量让“(”在左边,“)”在右边。

int cmp(node a,node b){
	if(a.l <= a.r && b.r < b.l){
		return 0;
	}
	//)))))))((((
	//))))(((((((
	else if(a.l > a.r && b.r >= b.l){
		return 1;
	}
	//))))(((((((
	//)))))))((((
	else if(a.r >= a.l && b.r >= b.l){
		return a.l > b.l;
	}
	//))))(((((((
	//))))))(((((
	else{
		return a.r < b.r;
	}
	//)))))
	//)))))))
}

排完序后可以将他们符合的答案加起来乘二。

 

答案:

#include<bits/stdc++.h>
using namespace std;

struct node{
	int l,r,num;
}a[100001];

int cmp(node a,node b){
	if(a.l <= a.r && b.r < b.l){
		return 0;
	}
	//)))))))((((
	//))))(((((((
	else if(a.l > a.r && b.r >= b.l){
		return 1;
	}
	//))))(((((((
	//)))))))((((
	else if(a.r >= a.l && b.r >= b.l){
		return a.l > b.l;
	}
	//))))(((((((
	//))))))(((((
	else{
		return a.r < b.r;
	}
	//)))))
	//)))))))
}

char b[100001];
int main(){
	int t,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i = 0 ; i < n ; i++){
			scanf("%s",b);
			a[i].num = a[i].l = a[i].r = 0;
			int len = strlen(b);
			for(int j = 0 ; j < len ; j++){
				if(b[j]=='('){
					a[i].l++;
				}
				else{
					if(a[i].l){
						a[i].num++;
						a[i].l--;
					}else{
						a[i].r++;
					}
				}
			}
		}
		sort(a,a+n,cmp);
		long long ans = 0;
		long long left = 0;
		for(int i = 0 ; i < n ; i++){
			ans += a[i].num;
			if(left && a[i].r){
				if(left > a[i].r){
					ans += a[i].r;
					left -= a[i].r;
				}else{
					ans += left;
					left = 0;
				}
			}
			left += a[i].l;
		}
		printf("%lld\n",ans*2);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值