2018 Multi-University Training Contest 2(HDU 6318)

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1165    Accepted Submission(s): 436


 

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

 

 

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

 

 

Output

For every test case, a single integer representing minimum money to pay.

 

 

Sample Input

 

3 233 666

1 2 3

3 1 666

3 2 1

 

 

Sample Output

 

0

3

 

 

Source

2018 Multi-University Training Contest 2

 

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6318 6317 6316 6315 6314 

 

比赛时用的是归并排序过的这里试一下树状数组。

题解:就是求出数组中的逆序数然后比较x,y大小,取小的来乘以逆序数即是答案。为了减小数字大小用了离散化。

答案:

#include<bits/stdc++.h>
using namespace std;

int n,tree[100001],b[100001],x,y;

struct node{
	int x,i;
	bool operator < (const node &a) const{
		if(x!=a.x){
			return x < a.x;
		}else{
			return i < a.i;
		}
	}
}p[100001];

void add(int k , int sum){
	while(k<=n){
		tree[k] += sum;
		k += k&-k;
	}
}

int query(int k){
	int sum = 0;
	while(k){
		sum += tree[k];
		k -= k&-k;
	}
	return sum;
}

int main(){
	while(~scanf("%d%d%d",&n,&x,&y)){
		memset(tree,0,sizeof(tree));
		memset(b,0,sizeof(b));
		memset(p,0,sizeof(p));
		for(int i = 1 ; i <= n ; i++){
			scanf("%d",&p[i].x);
			p[i].i = i;
		}
		sort(p+1,p+n+1);
		int cnt = 1;
		for(int i = 1 ; i <= n ; i++){
			if(i!=1&&p[i].x != p[i-1].x){
				cnt++;
			}
			b[p[i].i] = cnt;
		}
		long long sum = 0;
		for(int i = 1 ; i <= n ; i++){
			add(b[i],1);
			sum += i - query(b[i]);
		}
		printf("%lld\n",min(x*sum,y*sum));
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值