Billboard
Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26538 Accepted Submission(s): 10848
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1
Author
hhanger@zju
Source
HDOJ 2009 Summer Exercise(5)
题意:
一块高为h,宽为w的广告板,每个广告的高度均为一,且放的时候靠左上放(先考虑层数),给你广告的宽度wi,求能放下的最小层数。
思路:
可以开个数组记录1-h每层还可以放的最大宽度,每次输入时查找能放下的第一个位置,更新,继续下一次输入。
h , w 都是 109 10 9 ,而 n 是 105 10 5 , 每块广告牌高度为 1,即使一层放一个广告牌,那也才占用 105 10 5 ,所以可以把高度范围缩小至 105 10 5 。
可以用线段树进行查找更新。线段树维护的值是区间内能放下的最大值,树初始化为广告板的宽度(也可以初始化为空树,则线段树维护的值是区间内已经放的宽度值的最小值,后续代码便是采用这种),查询位置时顺便更新节点;
#include<iostream>
#include<cstdio>
#include<cstring>
const int maxn = 200010;
using namespace std;
int sum[maxn << 2], v, x; //x=w-v
int query(int pos, int l, int r) {
if (sum[pos] > x)
return -1;
if (l == r) {
sum[pos] += v;
return l;
}
int ans = 0;
int mid = (l + r) >> 1;
if (sum[pos << 1] <= x)
ans = query(pos << 1, l, mid);
else
ans = query(pos << 1 | 1, mid + 1, r);
sum[pos] = min(sum[pos << 1], sum[pos << 1 | 1]);
return ans;
}
int main() {
int n, h, w;
while (~scanf("%d%d%d", &h, &w, &n)) {
memset(sum, 0, sizeof(sum));
for (int i = 0; i < n; i++) {
scanf("%d", &v);
x = w - v;
printf("%d\n", query(1, 1, min(h,n)));
}
}
return 0;
}