田忌赛马 hdu1052

最近进行贪心的学习,偶遇一道神题,经典的田忌赛马,卡了我好久,关键是思路太乱,不懂如何处理打平情况,后来借鉴了网上的做法,总算弄了出来,现在总结一下

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1052

题目描述:

Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0

思路写在代码中,下面贴代码:

/*思路如下:
1,先按能力递减排序;
2,每次只比较最好的马;
3,如果赢不了,就比较最差的马,能赢就让它们比,不能赢(包括打平,整个过程都尽可能避免打平),就把它拉来和King的最好的马比(正所谓死的有价值,这是核心思想)
4,如果剩下的所有马的能力完全相同,就肯定是平了,结束比较
*/
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n,spT[1005],spK[1005];
bool flagT[1005],flagK[1005];
bool cmp(const int &a,const int &b)
{
    return a>b;
}
void change()//把King的马集体前移,n--,相当于拿Tian的最后一匹马和King最好的一匹马比
{
    for(int i=0;i<n-1;i++)
        spK[i]=spK[i+1];
    n--;
}
void change2()//当前Tian的最好的马比King的最好的马还快,直接把最好的和最好的比
{
    for(int i=0;i<n-1;i++)
    {
        spT[i]=spT[i+1];
        spK[i]=spK[i+1];
    }
    n--;
}
int getAns()
{
    int c=0;
    while(1)
    {
        if(n==0)
            break;
        int cc=0;
        /***********************/
        //完全相同肯定打平
        for(int i=0;i<n;i++)
            if(spT[i]!=spK[0]||spK[i]!=spK[0])//要完全相同才能跳出
                cc++;
        if(cc==0)
            break;
        /***********************/
        if(spT[0]<=spK[0])
        {
            for(int i=n-1;i>=0;i--)
            {
                if(spT[i]<=spK[i])//如果Tian最差的马不能赢King最差的马,就让它和King最好的马比
                {
                    n=i+1;
                    if(spT[i]<spK[0])//Tian最差的马有可能和King最好的马打平
                        c--;
                    change();
                    break;
                }
                c++;
            }
        }
        else
        {
            c++;
            change2();
        }
    }
    return c;
}
int main()
{
    while(1)
    {
        scanf("%d",&n);
        if(n==0)
            break;
        for(int i=0;i<n;i++)
            scanf("%d",&spT[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&spK[i]);
        memset(flagK,true,sizeof(flagK));
        memset(flagT,true,sizeof(flagT));
        sort(spT,spT+n,cmp);
        sort(spK,spK+n,cmp);
        printf("%d\n",getAns()*200);
    }
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值