Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
题意 求最小循环节的循环次数 如果不存在最小循环节 输出1.
代码
#include<stdio.h>
#include<string.h>
int l;
int next[1000020];
void getnext(char ss[])
{
int i=0,j=-1;
next[0]=-1;
while(i<l)
{ //j=-1说明不会发生匹配 或者 i与j发生匹配
//两种情况都要向右移动一位,
if(j==-1||ss[i]==ss[j])
{
i++;
j++;
next[i]=j;//最大前缀和最大后缀的匹配长度
//abfcab next[6]=2 匹配ab
//ababab next[6]=4 匹配abab
}
else
j=next[j];//回溯到之前不匹配的地方
}
}
char s[1000020];
int main()
{
while(~scanf("%s",s))
{
if(s[0]=='.')
break;
l=strlen(s);
getnext(s);
int t=l-next[l];//最小循环节
if(l%t==0)
printf("%d\n",l/t);//循环次数
else
printf("1\n");
}
return 0;
}