KMP算法

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3

题意 求最小循环节的循环次数 如果不存在最小循环节 输出1.
代码

#include<stdio.h>
#include<string.h>
int l;
int next[1000020];
void getnext(char ss[])
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<l)
    {   //j=-1说明不会发生匹配  或者 i与j发生匹配
        //两种情况都要向右移动一位,
        if(j==-1||ss[i]==ss[j])
        {
            i++;
            j++;
            next[i]=j;//最大前缀和最大后缀的匹配长度
            //abfcab  next[6]=2    匹配ab
            //ababab  next[6]=4    匹配abab
        }
        else
            j=next[j];//回溯到之前不匹配的地方
    }
}
char s[1000020];
int main()
{
    
    while(~scanf("%s",s))
    {
        if(s[0]=='.')
            break;
        l=strlen(s);
        getnext(s);
        int t=l-next[l];//最小循环节
        if(l%t==0)
            printf("%d\n",l/t);//循环次数
        else
            printf("1\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值