PAT考试乙级1007之素数对猜想
题目:
让我们定义d
n为:dn=pn+1−pn,其中pi是第i个素数。显然有d1=1,且对于n>1有dn是偶数。“素数对猜想”认为“存在无穷多对相邻且差为2的素数”。
现给定任意正整数N(<105),请计算不超过N的满足猜想的素数对的个数。
输入格式:
输入在一行给出正整数N。
输出格式:
在一行中输出不超过N的满足猜想的素数对的个数。
输入样例:
20
输出样例:
4
代码:
#pragma warning(disable:4996)
#include <stdio.h>
#include <string.h>
#include<stdlib.h>
#include <memory.h>
#include <math.h>
int main(void)
{
int a = 0, b = 3, i = 0, flag = 1, c = 0, n = 0;
scanf("%d", &a);
while (b <= a)
{
for (i = 2; i < sqrt(b) + 1; i++)
{
if (b % i == 0)
{
flag = 0;
}
}
if (flag == 0)
{
c = 0;
}
if (flag == 1)
{
c++;
}
if (c == 2)
{
n++;
c = 1;
}
b = b + 2;
flag = 1;
}
printf("%d\n", n);
// array = (int*)malloc(n * (sizeof(int)));
// free(array);
return 0;
}
这道题主要是超时的问题,一个数只需要判断到它的根号就能知道是不是素数了。