1003(树状数组+逆序对)

Problem Description
Recently yifenfei face such a problem that give you millions of positive integers,tell how many pairs i and j that satisfy F[i] smaller than F[j] strictly when i is smaller than j strictly. i and j is the serial number in the interger sequence. Of course, the problem is not over, the initial interger sequence will change all the time. Changing format is like this [S E] (abs(E-S)<=1000) that mean between the S and E of the sequece will Rotate one times.
For example initial sequence is 1 2 3 4 5.
If changing format is [1 3], than the sequence will be 1 3 4 2 5 because the first sequence is base from 0.

Input
The input contains multiple test cases. Each case first given a integer n standing the length of integer sequence (2<=n<=3000000) Second a line with n integers standing F[i](0<F[i]<=10000) Third a line with one integer m (m < 10000) Than m lines quiry, first give the type of quiry. A character C, if C is ‘R’ than give the changing format, if C equal to ‘Q’, just put the numbers of satisfy pairs.

Output
Output just according to said.

Sample Input
  
  
5 1 2 3 4 5 3 Q R 1 3 Q

Sample Output
  
  
10 8
题目大概:

求逆序对数,并且要让一个区间的数循环一遍,找出最大的逆序对数。

思路:
先按照模板把逆序对数求出来,然后把区间的数依次循环,求出每个数字位置改变后的新逆序对数。然后选出最大的。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int a[3000000];
int c[10001];

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int v)
{
    while(x<=10001)
    {
        c[x]+=v;
        x+=lowbit(x);
    }

}

long long sum(int x)
{
    long long sum=0;
    while(x>0)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
    long long ans=0;
    memset(c,0,sizeof(c));
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        ans+=sum(a[i]-1);
        add(a[i],1);

    }
    scanf("%d",&m);
    char fi[2];
    int q,w,vv;
    while(m--)
    {

        scanf("%s",fi);

        if(fi[0]=='Q')
        {
            printf("%I64d\n",ans);
        }
        else
        {

            scanf("%d%d",&q,&w);
            vv=a[q];
            for(int i=q;i<w;i++)
            {
                a[i]=a[i+1];

                if(vv>a[i])ans++;
                if(vv<a[i])ans--;
            }
            a[w]=vv;

        }
    }

    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值