1001(树状数组基本操作的合集)

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. There are 4 kind of queries, sum, add, delete and move. For example: S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. A x1 y1 n1 means I put n1 books on the position (x1,y1) D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. For each "S" query, just print out the total number of books in that area.

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4

题目大概:

在一个二维地图上,进行搬书操作,可以在一个位置增加书,可以把书从一个位置移动到另一个位置。可以从一个地方把书拿走。还有查看某个点的书的数量。

思路:

这个题包含了单点更新,区间更新,单点求值,还有一些实际问题的局限性。

需要注意的就是这个题的地图包含(0,0);

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

int n;
int c[1050][1050];
int a[1050][1050];

int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int y,int v)
{
    for(int i=x;i<=1010;i+=lowbit(i))
    {
        for(int j=y;j<=1010;j+=lowbit(j))
        c[i][j]+=v;

    }
}

long long sum(int x,int y)
{
    long long su=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
        su+=c[i][j];

    }
    return su;
}
int main()
{
    int t;
    scanf("%d",&t);
    int h=1;
    while(t--)
    {
        int m;
         printf("Case %d:\n",h++);

        memset(c,0,sizeof(c));
        memset(a,0,sizeof(a));
           for(int i=1;i<=1001;i++)
       {
        for(int j=1;j<=1001;j++)
        {   a[i][j]=1;
            add(i,j,1);
        }
       }
         scanf("%d",&m);
        while(m--)
        {
            char p[2];
             scanf("%s",p);

             if(p[0]=='A')
             {
                 int w1,w2,e1;
                  scanf("%d%d%d",&w1,&w2,&e1);
                  w1++;w2++;
                  add(w1,w2,e1);
                  a[w1][w2]+=e1;

             }
             else if(p[0]=='S')
             {
                 int r1,r2,w1,w2;
                 scanf("%d%d%d%d",&r1,&r2,&w1,&w2);
                 r1++;r2++;w1++;w2++;
                 if(r1>w1)swap(r1,w1);
                 if(r2>w2)swap(r2,w2);
                 int sun=0;
                 sun=sum(w1,w2)-sum(w1,r2-1)-sum(r1-1,w2)+sum(r1-1,r2-1);

                 printf("%d\n",sun);
             }
             else if(p[0]=='D')
             {    int w1,w2,e1;
                  scanf("%d%d%d",&w1,&w2,&e1);
                  w1++;w2++;
                  if(e1>a[w1][w2])e1=a[w1][w2];
                  add(w1,w2,-e1);
                  a[w1][w2]-=e1;

             }
             else if(p[0]=='M')
             {
                int r1,r2,w1,w2,n1;
                 scanf("%d%d%d%d%d",&r1,&r2,&w1,&w2,&n1);
                 r1++;r2++;w1++;w2++;
                   if(n1<=a[r1][r2])
                   {add(r1,r2,-n1);
                     add(w1,w2,n1);
                     a[r1][r2]-=n1;
                     a[w1][w2]+=n1;

                   }
                   else
                   {
                      add(w1,w2,a[r1][r2]);

                     add(r1,r2,-a[r1][r2]);
                     a[w1][w2]+=a[r1][r2];
                     a[r1][r2]=0;

                   }


             }

        }


    }





    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值