self 同类分布 (数位dp)

给出a,b,求出[a,b]中各位数字之和能整除原数的数的个数。
Sample Input
10 19
Sample Output
3
Hint

【约束条件】1 ≤ a ≤ b ≤ 10^18


题目大概:

题目比较简短。

思路:

这个题时间限制比较大,数据又比较大,所以可以枚举各位数字之和来解决问题,因为最多18位,最大为9,所以各位和最大为162。

枚举各位和,找出符合题目要求的条件的数字的个数,即列两个状态就可以了。

注意精度!

代码:


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>

using namespace std;
typedef long long ll;
ll a[22],f[22];
ll dp[22][163][163][2];

ll dpp(int pos,int sum,int b,int mo,bool limit)
{
    if(!pos)return sum==0&&b==0;
    if(dp[pos][sum][b][limit]!=-1)return dp[pos][sum][b][limit];
    ll sun=0;
    int end=limit?a[pos]:9;
    for(int i=0;i<=end;i++)
    {
        if(sum-i<0)break;
        sun+=dpp(pos-1,sum-i,(b*10+i)%mo,mo,limit&&i==a[pos]);

    }
    dp[pos][sum][b][limit]=sun;
    return sun;
}

ll go(ll x)
{
    int pos=0;
    while(x)
    {
        a[++pos]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int mo=1;mo<=pos*9;mo++)
    {
        memset(dp,-1,sizeof(dp));
        ans+=dpp(pos,mo,0,mo,1);
    }
    return ans;
}


int main()
{
    ll n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        printf("%lld\n",go(m)-go(n-1));
    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值