Game of Sum (区间dp)

This is a two player game. Initially there are n integer numbers in an array and players A and B get
chance to take them alternatively. Each player can take one or more numbers from the left or right end
of the array but cannot take from both ends at a time. He can take as many consecutive numbers as
he wants during his time. The game ends when all numbers are taken from the array by the players.
The point of each player is calculated by the summation of the numbers, which he has taken. Each
player tries to achieve more points from other. If both players play optimally and player A starts the
game then how much more point can player A get than player B?
Input
The input consists of a number of cases. Each case starts with a line specifying the integer n (0 <
n ≤ 100), the number of elements in the array. After that, n numbers are given for the game. Input is
terminated by a line where n = 0.
Output
For each test case, print a number, which represents the maximum difference that the first player
obtained after playing this game optimally.
Sample Input
4
4 -10 -20 7
4
1 2 3 4
0
Sample Output

7

10

题目大概:

给出n个数,有两个人从这个数列中取数。每个人只能从一边取1个或者多个。问两个玩家的最大差值。

思路:

用区间dp,用前缀和记录数的和。

dp【i】【j】是在区间 i 到 j  取数的最大可能。

枚举每个区间a玩家的取数的最小可能。然后用前缀和算出,这个区间的最大取数可能。最后最大和最小相减。

代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn=110;
const int INF=0x3f3f3f3f;
int a[maxn];
int sum[maxn];
int dp[maxn][maxn];
//
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
            dp[i][i]=a[i];
        }
        for(int i=2;i<=n;i++)
        {
            for(int l=1;l<=n-i+1;l++)
            {
                int r=l+i-1;
                int su=INF;
                for(int i=l;i<=r;i++)
                {
                    su=min(dp[l][i],su);
                }
                for(int i=r;i>=l;i--)
                {
                    su=min(su,dp[i][r]);
                }
                dp[l][r]=sum[r]-sum[l-1]-su;
            }
        }
        printf("%d\n",2*dp[1][n]-sum[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值