And Then There Was One (约瑟夫环变形)

Let’s play a stone removing game.
Initially, n stones are arranged on a circle and numbered 1, . . . , n clockwise (Figure 1). You are also
given two numbers k and m. From this state, remove stones one by one following the rules explained
below, until only one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise
from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step,
make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip
(k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left
and answer its number.
For example, the answer for the case n = 8, k = 5, m = 3 is 1, as shown in Figure 1.
Figure 1: An example game
Initial state: Eight stones are arranged on a circle.
Step 1: Stone 3 is removed since m = 3.
Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7
(since k = 5), and remove the next one, which is 8.
Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that
are still on the circle and ignore those already removed. Stone 3 is ignored in this case.
Steps 4-7: You continue until only one stone is left. Notice that in later steps when only a few
stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped
twice in step 7.
Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.
Input
The input consists of multiple datasets each of which is formatted as follows.
n k m
The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a
single space. A dataset satisfies the following conditions.
2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n
The number of datasets is less than 100.
Output
For each dataset, output a line containing the stone number left in the final state. No extra characters
such as spaces should appear in the output.
Sample Input
8 5 3
100 9999 98
10000 10000 10000
0 0 0
Sample Output
1
93
2019

题目大概:

给出n个人成环,报数从m开始,每次报数间隔k个人。

思路:

正常约瑟夫环是从1号开始,如果从m号,那么就是报数延迟到了m,那最后报数的人也会相应延迟m。

代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=11000;
int dp[maxn];

int main()
{
    int n,k,m;
    while(~scanf("%d%d%d",&n,&k,&m))
    {
        if((n+k+m)==0)break;
        dp[1]=0;
        for(int i=2;i<n;i++)
        {
            dp[i]=(dp[i-1]+k)%i;
        }
        printf("%d\n",(dp[n-1]+m)%n+1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
约瑟夫环问题是一道经典的数学问题,题目为:已知 n 个人(以编号 1,2,3 … n 分别表示)围成一圈,从第 k 个人开始报数,数到 m 的那个人出列,它的下一位又从 1 开始报数,数到 m 的那个人又出列,依次类推,直到所有人出列为止,由此产生一个出队编号的序列。 以下是使用 C 语言实现约瑟夫环问题的代码: ```c #include <stdio.h> int josephus(int n, int k, int m) { int i, s = 0; for (i = 2; i <= n; i++) s = (s + k) % i; s = (s + m) % n; return s + 1; } int main() { int n, k, m; printf("请输入 n, k, m 的值:"); scanf("%d%d%d", &n, &k, &m); printf("最后留下的人的编号是:%d\n", josephus(n, k, m)); return 0; } ``` 函数 `josephus` 的参数分别为 n,k,m,表示有 n 个人,从第 k 个人开始报数,数到 m 的那个人出列。函数的返回值为最后留下的人的编号。 在函数中,首先初始化变量 s 为 0,然后循环 n-1 次,每次计算出下一个出列的人的编号。具体来说,第 i 次循环时,假设前 i-1 个人已经出列,当前还剩下 n-i+1 个人,而上一次出列的人是编号为 s 的人,那么本次出列的人的编号为 (s+k) % i,其中 "%" 表示取模运算。最后剩下的那个人就是最后留下的人,其编号为 (s+m) % n。 在 `main` 函数中,从标准输入读入 n,k,m 的值,然后调用 `josephus` 函数计算最后留下的人的编号,并输出结果。 翻译如下: The Josephus problem is a classic mathematical problem. Given n people (represented by the numbers 1, 2, 3, ..., n) in a circle, starting from the kth person, count m people clockwise and remove the mth person. The next person starts counting from 1 again, and the process repeats until all people are removed, resulting in a sequence of removed numbers. The following is a C program to implement the Josephus problem: (略) The function `josephus` takes three parameters n, k, and m, representing the number of people, the starting point, and the count for removal, respectively. The function returns the number of the last person remaining. In the function, the variable s is initialized to 0, and the loop runs n-1 times, calculating the number of the next person to be removed each time. Specifically, in the i-th iteration, assuming the previous i-1 people have been removed, there are still n-i+1 people left, and the last removed person has the number s. The number of the current person to be removed is (s+k) % i, where "%" denotes the modulo operation. The last person remaining is the one with the number (s+m) % n. In the `main` function, the values of n, k, and m are read from standard input, and the `josephus` function is called to calculate the number of the last person remaining. The result is then output.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值