【题解】1015 Reversible Primes (20分)⭐⭐【进制转换】

1015 Reversible Primes (20分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Examples

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No




题意:

稍微有点绕,给出一个十进制数,如果它及它转为D进制后的数的反过来转为10进制都是素数,则输出Yes,否则输出No

题解:

一道练习进制转换的好题目,10转R,R转10一块练了
判断素数注意考虑1的情况


#include<bits/stdc++.h>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const int INF = 1 << 30;
const int MAXN = 1e5+10;

int tran(int r, int n){
    string s;
    while(n > 0){
        int t = n%r;
        n /= r;
        s += '0'+t;
    }
    int len = s.length(), ret = 0;
    for(int i = 0; i < len; ++i)
        ret += (s[i]-'0')*pow(r, len-i-1);
    return ret;
}
bool isPrime(int n){
    if(n < 2) return false;
    for(int i = 2; i <= sqrt(n); ++i)
        if(n % i == 0)
            return false;
    return true;
}
int main() {
    ios::sync_with_stdio(false);
    int n, d;
    while(cin >> n){
        if(n < 0) break;
        cin >> d;
        if(isPrime(n) && isPrime(tran(d, n)))
            cout << "Yes\n";
        else
            cout << "No\n";
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值