Description
Ordinal numbers refer to a position in a series. Common ordinals include zeroth, first, second, third, fourth and so on. Ordinals are not often written in words, they are written using digits and letters. An ordinal indicator is a sign adjacent to a numeral denoting that it is an ordinal number, rather than a cardinal number. In English, the suffixes -st (e.g. 21st), -nd (e.g. 22nd), -rd (e.g. 23rd), and -th (e.g. 24th) are used. The rules are as follows:
- If the tens digit of a number is 1, then write "th" after the number. For example: 13th, 19th, 112th, 9311th.
- If the tens digit is not equal to 1, then use "st" if the units digit is 1, "nd" if the units digit is 2, "rd" if the units digit is 3, and "th" otherwise: For example: 2nd, 7th, 20th, 23rd, 52nd, 135th, 301st.
Input
There are multiple test cases. The first line of input is an integer T ≈ 1000 indicating the number of test cases.
Each test case consists of a cardinal number 0 ≤ n < 1,000,000,000.
Output
For each test case, output the corresponding ordinal number.
Sample Input
5 1 2 3 4 1024
Sample Output
1st 2nd 3rd 4th 1024th
简单易懂,废话不多说
#include<iostream>
using namespace std;
int main()
{
int t;
cin>>t;
while(t--)
{
int num;
cin>>num;
if(num%10==1&&(num-11)%100!=0)
cout<<num<<"st"<<endl;
else if(num%10==2&&(num-12)%100!=0)
cout<<num<<"nd"<<endl;
else if(num%10==3&&(num-13)%100!=0)
cout<<num<<"rd"<<endl;
else
cout<<num<<"th"<<endl;
}
return 0;
}