Prime Ring Problem

Prime Ring Problem HDU - 1016

题目

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.
Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题目大意

输入一个整数n (0<n<20) 使得1 到 n ,n个数构成一个质数环,保证每相邻的两个数的和是质数,第一个数都从1开始。输出所有的情况。

分析与思路

利用dfs遍历每一个位置可以填的数的所有情况,如果遍历到第n+1位,并且最后一位所填的数与第一位的数之和为质数,意味着前面 n 位已经填好,输出此情况,并返回。注意dfs语句后面要恢复现场。

具体代码

#include<iostream>
#include<cstring>
using namespace std;
const int N=30;
int num[N];
bool st[N];
int n;
bool prim(int x)
{
    for(int i=2;i*i<=x;i++)
        if(x%i==0)return false;
    return true;
}
void dfs(int step)
{
    if(step==n&&prim(num[n-1]+1))
    {
        cout<<num[0];
        for(int i=1;i<n;i++)cout<<" "<<num[i];
        cout<<endl;
    }
    if(step==n)return;
    for(int i=2;i<=n;i++)
    {
        if(st[i]==true||prim(num[step-1]+i)==false)continue;
        st[i]=true;
        num[step]=i;
        dfs(step+1);
        st[i]=false;
    }
}
int main()
{
    int k=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(num,0,sizeof num);
        num[0]=1;
        st[1]=true;
        printf("Case %d:\n",k++);
        dfs(1);
        cout<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值