一元多项式求导

一元多项式求导

设计函数求一元多项式的导数。

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

标程

#include<map>
#include<list>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdio>
#include<vector>
#include<iomanip>
#include<cstring>
#include<iterator>
#include<iostream>
#include<algorithm>
#define R register
#define LL long long
#define pi 3.141
#define INF 1400000000
using namespace std;

int main() {
	int num_1[11000];
	int num_2[11000];
	int flag = 0;
	int count = 0;
	int num1, num2;
	while (scanf("%d%d", &num1, &num2)) {                    //读取数据
		if (num2 != 0) {
			num_1[flag] = num1 * num2, num_2[flag] = num2 - 1; //数据处理
			++flag, ++count;
		}
		char ch = getchar();                                 //读数结束判断
		if (ch == '\n') {
			break;
		}
	}
	if (count == 0) {                                        //多项式为0判断
		printf("0 0");
		return 0;
	}
	for (R int i = 0; i < count; ++i) {                      //计数输出
		cout << num_1[i] << " " << num_2[i];
		if (i < count - 1) {
			cout << " ";
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值