思科模拟器常用命令总结

最近在思科模拟器上做无线网络搭建的实验。原例是PT-练习上的WRT300N无线路由器练习,这里将用到的一些命令做一个总结。之前做实验敲的命令较少,而这个是只能手动输入命令。在网上查找有些命令花费了不少时间,最重要的是记住命令,而不是花费太多的时间在查找命令。这个实验还没做完,有一个环节命名的问题,按照正确的操作步骤,但还是出现问题,找不到解决的方法。虽然对最终的结果不会有影响,但是,还是不想在往下做了。

常用命令

路由器命令

1,路由器口令设置:

router>enable                           进入特权模式
router#config terminal                  进入全局配置模式
router(config)#hostname <hostname>      设置交换机的主机名
router(config)#enable secret xxx        设置特权加密口令
router(config)#enable password xxb      设置特权非密口令
router(config)#line console 0           进入控制台口
router(config-line)#line vty 0 4        进入虚拟终端
router(config-line)#login               要求口令验证
router(config-line)#password xx         设置登录口令xx
router(config)#(Ctrl+z)                 返回特权模式
router#exit                             返回命令
   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11

2,路由器配置:

router(config)#int s0/0                             进入Serail接口
router(config-if)#no shutdown                       激活当前接口
router(config-if)#clock rate 64000                  设置同步时钟
router(config-if)#ip address <ip> <netmask>         设置IP地址
router(config-if)#ip address <ip> <netmask> second  设置第二个IP
router(config-if)#int f0/0.1                        进入子接口
router(config-subif.1)#ip address <ip> <netmask>    设置子接口IP
router(config-subif.1)#encapsulation dot1q <n>      绑定vlan中继协议
router(config)#config-register 0x2142               跳过配置文件
router(config)#config-register 0x2102               正常使用配置文件
router#reload                                       重新引导

   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12

3,路由器文件操作:


router#copy running-config startup-config           保存配置
router#copy running-config tftp                     保存配置到tftp
router#copy startup-config tftp                     开机配置存到tftp
router#copy tftp flash:                             下传文件到flash
router#copy tftp startup-config                     下载配置文件
ROM状态:
Ctrl+Break                                          进入ROM监控状态
rommon>confreg 0x2142                               跳过配置文件
rommon>confreg 0x2102                               恢复配置文件
rommon>reset                                        重新引导
rommon>copy xmodem:<sname> flash:<dname>            从console传输文件
rommon>IP_ADDRESS=10.65.1.2                         设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0                   设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1                        指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin                          指定下载的文件
rommon>tftpdnld                                     从tftp下载
rommon>dir flash:                                   查看闪存内容
rommon>boot                                         引导IOS
   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19

4,静态路由:

ip route <ip-address> <subnet-mask> <gateway>       命令格式
router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2   静态路由举例
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2     默认路由举例
   
   
  • 1
  • 2
  • 3

5,动态路由:

router(config)#ip routing                          启动路由转发
router(config)#router rip                          启动RIP路由协议。
router(config-router)#network <netid>              设置发布路由
router(config-router)#negihbor <ip>                点对点帧中继用。
   
   
  • 1
  • 2
  • 3
  • 4

6,帧中继命令:

router(config)#frame-relay switching               使能帧中继交换
router(config-s0)#encapsulation frame-relay        使能帧中继
router(config-s0)#fram-relay lmi-type cisco        设置管理类型
router(config-s0)#frame-relay intf-type DCE        设置为DCE
router(config-s0)#frame-relay dlci 16              
router(config-s0)#frame-relay local-dlci 20        设置虚电路号
router(config-s0)#frame-relay interface-dlci 16 
router(config)#log-adjacency-changes             记录邻接变化
router(config)#int s0/0.1 point-to-point         设置子接口点对点
router#show frame pvc                            显示永久虚电路
router#show frame map                            显示映射
   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11

7,基本访问控制列表:

router(config)#access-list <number> permit|deny <source_ip> <wild|any>
router(config)#interface <interface>             ;default:deny any
router(config-if)#ip access-group <number> in|out   ;defaultut
   
   
  • 1
  • 2
  • 3
1:
router(config)#access-list 1 deny host 10.65.1.1
router(config)#access-list 1 permit any
router(config)#int f0/0
router(config-if)#ip access-group 4 in2:
router(config)#access-list 4 permit 10.8.1.1
router(config)#access-list 4 deny 10.8.1.0 0.0.0.255
router(config)#access-list 4 permit 10.8.0.0 0.0.255.255
router(config)#access-list 4 deny 10.0.0.0 0.255.255.255
router(config)#access-list 4 permit any
router(config)#int f0/1
router(config-if)#ip access-group 4 in
扩展访问控制列表:
access-list <number> permit|deny icmp <S_IP wild> <D_IP wild>[type]
access-list <number> permit|deny tcp <S_IP wild> <D_IP wild>[port]
例1:
router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
router(config)#access-list 101 permit ip any any
router(config)#int s0/0
router(config-if)#ip access-group 101 in2:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
router(config)#access-list 102 permit ip any any
router(config)#interface s0/1
router(config-if)#ip access-group 102 out
删除访问控制例表:
router(config)#no access-list 102
router(config-if)#no ip access-group 101 in
路由器的nat配置
Router(config-if)#ip nat inside              当前接口指定为内部接口
Router(config-if)#ip nat outside             当前接口指定为外部接口
Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]
Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
Router(config)#ip nat inside source list 1 pool p1
Router(config)#ip nat inside destination list 2 pool p2
Router(config)#ip nat inside source list 2 interface s0/0 overload
Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary
Router#show ip nat translation
rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。
外部网关协议配置
routerA(config)#router bgp 100
routerA(config-router)#network 19.0.0.0
routerA(config-router)#neighbor 8.1.1.2 remote-as 200
配置PPP验证:
RouterA(config)#username <RouterB> password <word>
RouterA(config)#int s0
RouterA(config-if)#ppp authentication {chap|pap}
   
   
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51

8,路由器子接口封装为8021Q (补充)

Encapsulation dot1q 2      封装类型设置为 802.1Q,2是子接口号标识,这里是示范,可以随意设置。
   
   
  • 1

结束

资料来自于网上,自己在做实验的时候参考了这份资料,很感谢提供资料的网友,这里将自己遇到的有些问题的命令做个补充。如果发现有错误的话,欢迎指出,有些命令自己也没有试过。后续还会更新交换机的相关命令。

  • 18
    点赞
  • 140
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值