动态库 libglog.so安装,libstdc升级

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a1368783069/article/details/88059968

1 loading shared libraries: libglog.so.0 找不到

下载glog ,然后编译安装

wget https://google-glog.googlecode.com/files/glog-0.3.3.tar.gz
tar zxvf glog-0.3.3.tar.gz
./configure

添加动态库搜索路径(其中一种方法)

/etc/ld.so.conf.d/

echo  " /usr/local/lib" >  libglog.conf

 ldconfig -v

2 `GLIBCXX_3.4.20’ not found
解决方法是升级libstdc++

sudo  yum provides libstdc++.so.6
# libstdc++-4.8.5-11.el7.i686 : GNU Standard C++ Library

sudo yum install   libstdc++-4.8.5-11.el7.i686

cp /usr/local/lib64/libstdc++.so.6.0.24 /usr/lib64
cd   /usr/lib64
mv  libstdc++.so.6 libstdc++.so.6_backup
ln -s  libstdc++.so.6.0.24   libstdc++.so.6

说明
升级gcc ,GLIBCXX_版本增加。 (可以直接编译安装gcc)
参考:
Linux动态库(.so)搜索路径
https://www.xuebuyuan.com/3189817.html

/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20’ not found问题解决方法
https://blog.csdn.net/libaineu2004/article/details/77100132

展开阅读全文

没有更多推荐了,返回首页