ACM2-1002

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 

Author
Redow
  首先,对该式子,求一阶导,得到F'(x) = 42*x^6 + 48*x^5+21*x^2+10*x-y,这里,我们忽略y,可发现,导函数42*x^6 + 48*x^5+21*x^2+10*x是递增的,范围在[0, 10^13],

所以我们可以发现无论y取什么值,总可以找到x1∈[0, 100],使F'(x1)=0,又因为此时x∈[0, x1]时,函数递减(导函数小于零,原函数递减,反之,递增);x∈[x1, 100]时,函数递增。所以F(x1)便是极小值,也是最小值。综上,先对F'(x)使用二分法即可,最后结果输出F(x)的值即可

#include<iostream>  
#include<stdio.h>  
#include<cmath>  
using namespace std;  
double f(double x,long long y)  
{  
    return (42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x-y);  
}  
int main()  
{  
    int t;  
    cin>>t;  
    while(t--)  
    {  
        double mid=50.0,m=0.0,n=100.0,x,s;  
        long long y;  
        cin>>y;  
        while(fabs(f(mid,y))>1e-5)  
        {  
            if((f(mid,y)>0))  
            {  
                n=mid;  
                mid=(m+n)/2;  
            }  
            else if(f(mid,y)<0)  
            {  
                m=mid;  
                mid=(m+n)/2;  
            }  
        }  
        x=mid;  
        s=6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;  
      cout<<s<<endl;  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值