ACM2-1016

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.<br><br>Write a program to count the number of black tiles which he can reach by repeating the moves described above. <br>
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.<br><br>There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.<br><br>'.' - a black tile <br>'#' - a red tile <br>'@' - a man on a black tile(appears exactly once in a data set) <br>
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). <br>
 

Sample Input
  
  
6 9<br>....#.<br>.....#<br>......<br>......<br>......<br>......<br>......<br>#@...#<br>.#..#.<br>11 9<br>.#.........<br>.#.#######.<br>.#.#.....#.<br>.#.#.###.#.<br>.#.#..@#.#.<br>.#.#####.#.<br>.#.......#.<br>.#########.<br>...........<br>11 6<br>..#..#..#..<br>..#..#..#..<br>..#..#..###<br>..#..#..#@.<br>..#..#..#..<br>..#..#..#..<br>7 7<br>..#.#..<br>..#.#..<br>###.###<br>...@...<br>###.###<br>..#.#..<br>..#.#..<br>0 0<br>
 

Sample Output
  
  
45<br>59<br>6<br>13<br>
 

Source
Asia 2004, Ehime (Japan), Japan Domestic
 
       使用深度优先搜索
#include <stdio.h>  
#include <string.h>  
  
int n,m,cnt;  
char map[30][30];  
int to[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};  
  
void dfs(int i,int j)  
{  
    cnt++;  
    map[i][j] = '#';  
    for(int k = 0; k<4; k++)  
    {  
        int x = i+to[k][0];  
        int y = j+to[k][1];  
        if(x<n && y<m && x>=0 && y>=0 && map[x][y] == '.')  
            dfs(x,y);  
    }  
    return;  
}  
  
int main()  
{  
    int i,j,fi,fj;  
    while(~scanf("%d%d%*c",&m,&n))  
    {  
        if(m == 0 && n == 0)  
            break;  
        for(i = 0; i<n; i++)  
        {  
            for(j = 0; j<m; j++)  
            {  
                scanf("%c",&map[i][j]);  
                if(map[i][j] == '@')  
                {  
                    fi = i;  
                    fj = j;  
                }  
            }  
            getchar();  
        }  
        cnt = 0;  
        //map[i][j] = '#';  
        dfs(fi,fj);  
        printf("%d\n",cnt);  
    }  
  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值