poj 1936 All in All

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31802 Accepted: 13204

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

提示

题意:

您设计了一种新的加密技术,它通过插入它的字符之间随机生成字符串的聪明方式来编码一个消息。我们将不会详细讨论字符串是如何生成并插入到原始消息中的。为了验证您的方法,有必要写一个程序来检查消息是否真的在字符串中。
给定两个字符串s和t,s通过插入字符是否能转化为t。

思路:

没有。

示例程序

Source Code

Problem: 1936		Code Length: 487B
Memory: 548K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int main()
{
    char ch[100001],ch1[100001];
    int k,l;
    while(scanf("%s %s",ch,ch1)!=EOF)
    {
        k=strlen(ch)-1;
        l=strlen(ch1)-1;
        while(k>=0&&l>=0&&l>=k)
        {
            if(ch[k]==ch1[l])
            {
                k--;
            }
            l--;
        }
        if(k<0)
        {
            printf("Yes\n");
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值