poj 3321 Apple Tree


Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27543 Accepted: 8166

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

提示

题意:
卡卡家门前有一个苹果树。每年秋天树上都长满了苹果树,苹果树有n(n<=100000 )个树 ,每个 树杈 上都长了一个苹果,对该树进行m(m<=100000)次操作,操作规则如下:
1.Q x;输出树杈x以及子树杈上有几个苹果。
2.C x;如果树杈x上没有苹果则长出一个,如果有则卡卡会拿走它。
思路:
先DFS该树得到一个序列,之后为这个序列的每个节点重新编号。
重新编号后,start[i]表示i节点所包含DFS序列的开始节点,end[i]表示i节点所包含DFS序列的终止节点。
这样产生了一个区间,单点更新,区间访问,树状数组。

示例程序

Source Code

Problem: 3321		Code Length: 1608B
Memory: 6608K		Time: 704MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int v,next;
}w[100001];
int c[100001],h[100001],start[100001],end[100001],numw,vis[100001],deep,apple[100001];
int lowbit(int x)
{
    return x&(-x);
}
void insert(int u,int v)
{
    w[numw].v=v;
    w[numw].next=h[u];
    h[u]=numw;
    numw++;
}
void dfs(int t)
{
    int i;
    deep++;
    start[t]=deep;
    for(i=h[t];i!=-1;i=w[i].next)
    {
        if(vis[w[i].v]==0)
        {
            vis[w[i].v]=1;
            dfs(w[i].v);
        }
    }
    end[t]=deep;
}
void update(int pos,int x,int n)
{
    while(pos<=n)
    {
        c[pos]=c[pos]+x;
        pos=pos+lowbit(pos);
    }
}
int Sum(int pos)
{
    int sum=0;
    while(pos>=1)
    {
        sum=sum+c[pos];
        pos=pos-lowbit(pos);
    }
    return sum;
}
int main()
{
    int n,i,u,v,m,x;
    char s[2];
    memset(h,-1,sizeof(h));
    memset(vis,0,sizeof(vis));
    memset(apple,0,sizeof(apple));		//我们设0时有苹果,为1时没有苹果
    memset(c,0,sizeof(c));
    numw=0;
    deep=0;
    scanf("%d",&n);
    for(i=1;n>i;i++)
    {
        scanf("%d %d",&u,&v);
        insert(u,v);				//建图
    }
    dfs(1);					//深搜重新编号
    for(i=1;n>=i;i++)				//c数组初始化
    {
        update(i,1,n);
    }
    scanf("%d",&m);
    for(i=1;m>=i;i++)
    {
        scanf("%s %d",s,&x);
        if(s[0]=='C')
        {
            if(apple[x]==0)
            {
                update(start[x],-1,n);
                apple[x]=1;
            }
            else
            {
                update(start[x],1,n);
                apple[x]=0;
            }
        }
        else
        {
            printf("%d\n",Sum(end[x])-Sum(start[x]-1));		//终止位置减去开始位置的值就是该节点上的数总和
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值