poj 1724 ROADS

ROADS
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14207 Accepted: 5170

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

Source

提示

题意;

有编号从1到n的n(2<=n<=100)个城市用一条路(有向)连着,其中它们有两个参数:长度l(1<=l<=100)和过路费t(0<=t<=100)。给出Bob最大能负担起过路总费用k(0<=k<=10000),求出从编号1到编号n城市的最短路径。如果Bob不能到达输出"-1"。

思路:

数据量不是很大,简单dfs加上一些剪枝就可以水过去了。用链式前向星可能会快点。

示例程序

Source Code

Problem: 1724		Code Length: 1103B
Memory: 544K		Time: 94MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int v,next,cost,l;
}w[10000];
int numw,h[100],v[100],n,len,k;		//numw:边的个数,len:最短路径
void insert(int s,int d,int l,int t)
{
    w[numw].v=d;
    w[numw].l=l;
    w[numw].cost=t;
    w[numw].next=h[s];
    h[s]=numw;
    numw++;
}
void dfs(int pos,int sum,int dfslen)
{
    int i;
    if(sum>k||dfslen>len)
    {
        return;
    }
    if(pos==n-1)
    {
        if(len>dfslen)
        {
            len=dfslen;
        }
        return;
    }
    for(i=h[pos];i!=-1;i=w[i].next)
    {
        if(v[w[i].v]==0)
        {
            v[w[i].v]=1;
            dfs(w[i].v,sum+w[i].cost,dfslen+w[i].l);
            v[w[i].v]=0;
        }
    }
}
int main()
{
    int i,s,d,l,t,r;
    scanf("%d",&k);
    scanf("%d",&n);
    scanf("%d",&r);
    memset(v,0,sizeof(v));
    memset(h,-1,sizeof(h));
    numw=0;
    len=1e9+7;
    for(i=1;r>=i;i++)
    {
        scanf("%d %d %d %d",&s,&d,&l,&t);
        insert(s-1,d-1,l,t);
    }
    dfs(0,0,0);
    if(len==1e9+7)
    {
        printf("-1");
    }
    else
    {
        printf("%d",len);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值