poj 2155 Matrix

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26969 Accepted: 9887

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
提示

题意:

一开始有n*n的矩阵其数值全为0,之后进行q次操作,操作方式如下:

C:x1 y1 x2 y2,对其子矩阵(x1~x2,y1~y2)的数值全部取反(0变1,1变0)。

Q:x1 y1,输出该点的数值。

思路:

二维树状数组。

该题不再详细累述,题解:https://wenku.baidu.com/view/1e51750abb68a98271fefaa8

示例程序

#include <cstdio>
#include <cstring>
using namespace std;
int n,c[1002][1002];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int y)
{
    int i,i1;
    for(i=x;n>=i;i=i+lowbit(i))
    {
        for(i1=y;n>=i1;i1=i1+lowbit(i1))
        {
            c[i][i1]++;
        }
    }
}
int main()
{
    int t,i,i1,i2,i3,q,x,y,x1,y1,ans;
    char op[2];
    scanf("%d",&t);
    for(i=1;t>=i;i++)
    {
        scanf("%d %d",&n,&q);
        memset(c,0,sizeof(c));
        for(i1=1;q>=i1;i1++)
        {
            scanf("%s %d %d",op,&x,&y);
            if(op[0]=='C')
            {
                scanf("%d %d",&x1,&y1);
                update(x,y);
                update(x,y1+1);
                update(x1+1,y);
                update(x1+1,y1+1);
            }
            else
            {
                ans=0;
                for(i2=x;i2!=0;i2=i2-lowbit(i2))
                {
                    for(i3=y;i3!=0;i3=i3-lowbit(i3))
                    {
                        ans=ans+c[i2][i3];
                    }
                }
                printf("%d\n",ans%2);
            }
        }
        if(i!=t)
        {
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值