ZOJ 3961 Let's Chat

Let's Chat

Time Limit: 1 Second       Memory Limit: 65536 KB

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last m consecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m+ 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ xy ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers lai and rai (1 ≤ lai ≤ rai ≤ n), indicating that A sent messages to B on each day between the lai-th day and the rai-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lbi and rbi (1 ≤ lbi ≤ rbi ≤ n), indicating that B sent messages to A on each day between the lbi-th day and the rbi-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < xrai + 1 < lai + 1 and for all 1 ≤ i < yrbi + 1 < lbi + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input
2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5
Sample Output
3
0
Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.


Author:  WENG, Caizhi
Source:  The 14th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple

提示

题意:

给出x(1<=x<=100)个区间和y(1<=y<=100)个区间,求出存在几个长度为m(1<=m<=n)公共子区间。

思路:

由于区间范围较大普通枚举肯定不行,我们实际上可以这样做,先求出第i个一区间和第j个二区间的公共区间,之后再看其中存在几个子区间,遍历完毕以后比较第i个一区间和第j个子区间的尾端,舍去比较小的那个(相等的话舍弃任意一个),若舍去的是一区间,i自增,否则j自增,直到一区间枚举完毕或者二区间枚举完毕。

样例解释:

一区间:(1,3),(5,8),(10,10)

二区间:(1,8),(10,10)

它们的共同区间为(1,3),子区间(1,3)符合条件,num=1;(1,3)中的3小于(1,8)中的8,i自增。

一区间:(1,3),(5,8),(10,10)

二区间:(1,8),(10,10)

它们的共同区间为(5,8),子区间(5,7),(6,8)符合条件,num=3;(5,8)中的8等于(1,8)中的8,舍去任意一个。(这里舍去一区间的)

一区间:(1,3),(5,8),(10,10)

二区间:(1,8),(10,10)

无共同区间,舍去二区间的。

一区间:(1,3),(5,8),(10,10)

二区间:(1,8),(10,10)

它们的共同区间为(10,10),没有符合条件的,舍去一区间的,一区间遍历完毕,结束。

最终结果为3.

示例程序

#include <cstdio>
#include <algorithm>
using namespace std;
struct jj
{
    int s,e;
}a[100],b[100];
int main()
{
    int t,n,m,x,y,i,i1,maxs,mine;
    long long sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d %d",&n,&m,&x,&y);
        for(i=0;x>i;i++)
        {
            scanf("%d %d",&a[i].s,&a[i].e);
        }
        for(i=0;y>i;i++)
        {
            scanf("%d %d",&b[i].s,&b[i].e);
        }
        sum=0;
        i=0;
        i1=0;
        while(x>i&&y>i1)
        {
            maxs=max(a[i].s,b[i1].s);
            mine=min(a[i].e,b[i1].e);
            if(mine-maxs+2-m>0)
            {
                sum=sum+mine-maxs+2-m;			//直接用公共区间长度减去m
            }
            if(a[i].e<=b[i1].e)
            {
                i++;
            }
            else
            {
                i1++;
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值