poj 1065 贪心算法

Wooden Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21899 Accepted: 9350

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source

 
 
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

struct Node{
    int x;
    int y;
};


int cmp(Node a,Node b)
{
    if(a.x==b.x) return a.y<b.y;
    return a.x<b.x;

}
int main()
{
    int t;
    int n;
    Node node[5005];
    bool flag[5005]; //标志是否已经分组
    while(cin>>t)
    {

        while(t--)
        {
            memset(flag,0,sizeof(flag));
            cin>>n;
            int ans=0;
            for(int i=0;i<n;i++)
                cin>>node[i].x>>node[i].y;
            sort(node,node+n,cmp);
            for(int i=0;i<n;i++)
            {
                if(flag[i]==0)
                {
                    int p=node[i].y;
                    for(int j=i;j<n;j++)
                    {
                        if(flag[j]==0&&node[j].y>=p) {flag[j]=1;p=node[j].y;}
                    }
                    ans++;

                }
            }
            cout<<ans<<endl;

        }
    }

}

   整体思路就是,先按照长度对结构体排序,再进行遍历分组,如果满足p<y就满足分组条件,就修改标志位,这样遍历一遍,有ans个0,就有ans组,答案就是ans;

转载于:https://www.cnblogs.com/hellohacker/p/5824137.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值