目录
题目概述:
1032 挖掘机技术哪家强 (20 分)
为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。
输入格式:
输入在第 1 行给出不超过 105 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。
输出格式:
在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。
输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0
输出样例:
2 150
源代码:
#include<iostream>
#include<algorithm>
using namespace std;
struct player
{
int no = 0;
int grades = -1;//初始化成绩为-1便于统计实际参赛学校的数量
};
void read(player &p)
{
cin >> p.no >> p.grades;
}
bool cmp(player a, player b)
{
return a.grades > b.grades;
}
const int maxn = 100001;
player players[maxn];
int main()
{
int N;
cin >> N;
player curr;
int all = 0;//实际参赛的学校数量
for (int i = 1; i <= N; ++i)
{
players[i].no = i;
}
for (int i = 0; i < N; ++i)
{
read(curr);
if (players[curr.no].grades < 0)
{
++all;
players[curr.no].grades = 0;
}
players[curr.no].grades += curr.grades;
}
sort(players + 1, players + all + 1, cmp);
cout << players[1].no << " " << players[1].grades << endl;
return 0;
}
分析思路:
1.本质其实就是一道排序题目,只不过同编码的成绩要相加而已,可以提前准备,把数组下标等同于学校编码(舍弃0下标位置),每次读入数据的时候都进行判断,同编码的成绩相加即可。
2.同时用一个all计数器记录下实际多少个不同参赛学校,便于sort函数的范围确定。(实际这题用STL容器应该更容易,不过我写道后面才发现,就没用了。)