promble 1000 搬桌子

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
解题思路:
该题按我理解是一种典型的并行资源配置问题
1.首先应定义一个结构来描述走廊
2.计算时应注意只计算重复占用次数最多的走廊数
3.要巧妙将房间和走廊数值互换
4.要设置一个 初始值为零的数组以便累加得到最大值
代码:
#include<iostream>
#include<algorithm>
using namespace std;
struct plan{

 int f;
 int s;
}a[200];
int main()
{
 int c[200]={0};
 int i,j;
 int n;
 int max=0;
 int m;
 cin>>n;
 for(i=0;i<n;i++)
 {
  cin>>a[i].s>>a[i].f;
  a[i].s=(a[i].s-1)/2;
  a[i].f=(a[i].f-1)/2;
  if(a[i].s>a[i].f)
  {
   int temp;
   temp=a[i].s;
   a[i].f=temp;
   a[i].s=a[i].f;
  }
  for(j=a[i].s;j<=a[i].f;j++)
   c[j]++;
  for(i=0;i<200;i++)
  {
   if(max<c[i])
    max=c[i];
  
  
  }
  cout<<max*10<<endl;
 }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
自动控制节水灌溉技术的高低代表着农业现代化的发展状况,灌溉系统自动化水平较低是制约我国高效农业发展的主要原因。本文就此问题研究了单片机控制的滴灌节水灌溉系统,该系统可对不同土壤的湿度进行监控,并按照作物对土壤湿度的要求进行适时、适量灌水,其核心是单片机和PC机构成的控制部分,主要对土壤湿度与灌水量之间的关系、灌溉控制技术及设备系统的硬件、软件编程各个部分进行了深入的研究。 单片机控制部分采用上下位机的形式。下位机硬件部分选用AT89C51单片机为核心,主要由土壤湿度传感器,信号处理电路,显示电路,输出控制电路,故障报警电路等组成,软件选用汇编语言编程。上位机选用586型以上PC机,通过MAX232芯片实现同下位机的电平转换功能,上下位机之间通过串行通信方式进行数据的双向传输,软件选用VB高级编程语言以建立友好的人机界面。系统主要具有以下功能:可在PC机提供的人机对话界面上设置作物要求的土壤湿度相关参数;单片机可将土壤湿度传感器检测到的土壤湿度模拟量转换成数字量,显示于LED显示器上,同时单片机可采用串行通信方式将此湿度值传输到PC机上;PC机通过其内设程序计算出所需的灌水量和灌水时间,且显示于界面上,并将有关的灌水信息反馈给单片机,若需灌水,则单片机系统启动鸣音报警,发出灌水信号,并经放大驱动设备,开启电磁阀进行倒计时定时灌水,若不需灌水,即PC机上显示的灌水量和灌水时间均为0,系统不进行灌水。
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个子系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
这段代码实现了哈夫曼编码的压缩功能,对输入的文件进行编码并输出压缩后的二进制文件。 具体解释见代码注释: ```c++ void HuffmanCoding::encode(ifstream& fIn) { // 初始化变量 unsigned long packCnt = 0, hold, maxPack = bytes * bits, pack = 0; char ch, ch2; int bitsLeft, runLength; // 循环直到读到文件末尾 for (fIn.get(ch); !fIn.eof();) { // 获取重复字符长度 for (runLength = 1, fIn.get(ch2); !fIn.eof() && ch2 == ch; runLength++) fIn.get(ch2); // 根据字符编码获取对应的哈夫曼编码 HuffmanNode* p = chars[(unsigned char)ch]; for (p = chars[(unsigned char)ch]; p != 0 && runLength != p->runLen; p = p->right); if (p == 0) cout<<("A promble in encode()"); // 判断编码是否能够直接放入压缩后的二进制文件中 if (p->codewordLen < maxPack - packCnt) { pack = (pack << p->codewordLen) | p->codeword; pack += p->codewordLen; } else { // 将编码拆分为两部分,一部分放入当前二进制文件中,另一部分等待下一次输出 bitsLeft = maxPack - packCnt; pack <<= bitsLeft; if (bitsLeft != p->codewordLen) { hold = p->codeword; hold >>= p->codewordLen - bitsLeft; pack |= hold; } else pack |= hold; output(pack); if (bitsLeft != p->codewordLen) { pack = p->codeword; packCnt = maxPack - (p->codewordLen - bitsLeft); packCnt = p->codewordLen - bitsLeft; } else packCnt = 0; } ch = ch2; // 更新当前字符 } // 输出剩余的编码 if (packCnt != 0) { pack <<= maxPack - packCnt; output(pack); } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值