problem G

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
题意:
上楼要花6分钟,下楼花4分钟,停留一次是指最后所停留楼花5分钟
思路:
1 熟练运用vector即可
2 别的就是注意将上下楼的动作转化为数组元素大小的比较判断
代码:
#include<iostream>
#include<vector>
using namespace std;
int main()
{
 int n,i;
 vector<int>a;
 int sum=0,m;
 a.push_back(0);
 while(cin>>n)
 {
  if(n<=0&&n>100)  break;
  for(i=1;i<=n;i++)
  {
   cin>>m;
   a.push_back(m);
  }
  
  for(i=1;i<a.size();i++)
  {
   if(a[i]>a[i-1])   sum+=(a[i]-a[i-1])*4;
   if(a[i]<a[i-1])   sum+=(a[i-1]-a[i])*6;
      if(a[i]=a[i-1])  sum+=5;
  }
  sum+=5;
  cout<<sum<<endl;
 }
 return 0;

}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值