SDUT2159 Ivan comes again!(省赛原题)(STL)

题目连接:http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=2159&cid=1172

示例输入

4
add 2 3
find 1 2
remove 2 3
find 1 2

0

示例输出

Case 1:
2 3
-1

题意:跟hello world题意差不多,第一行N个操作,“add”是加入容器一个数对,“remove”是在容器中删除这个数对,“find”是在容器中查找比这个数对都大的数对,没找到输出-1,如果有多个,行最小优先,行最小有多个,列最小优先。

题解:就是找这个容器,做的时候是想用set做,但觉得不会用set的删除操作。用pair存储数对,省去结构体的麻烦,pair->first是第一个元素, pair->second是第二个元素,用一个set存放set,set中的元素输入的时候就自动从小到大排序,这里的元素是pair类型,如果pair中的第一个数相同,则按第二个数排序,这和题目要求就相符了。还有lower_bound 和upper_bound两个函数。
<a target=_blank target="_blank" class="inner-link decor-none" href="http://zhidao.baidu.com/search?word=lower_bound&fr=qb_search_exp&ie=utf8" rel="nofollow" style="text-decoration: none; color: rgb(45, 100, 179);">lower_bound</a>(val): 返回容器中第一个值【大于或等于】val的元素的iterator位置。
<a target=_blank target="_blank" class="inner-link decor-none" href="http://zhidao.baidu.com/search?word=upper_bound&fr=qb_search_exp&ie=utf8" rel="nofollow" style="text-decoration: none; color: rgb(45, 100, 179);">upper_bound</a>(val): 返回容器中第一个值【大于】val的元素的iterator位置。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<set>
#include<string>
using namespace std;
int main()
{
    pair<int,int >p;
    int n;
    char str[10];
    int c=1;
    while(cin>>n&&n){
        cout<<"Case "<<c++<<":"<<endl;
        set< pair<int,int> >s;
        while(n--){
            scanf("%s%d%d",str,&p.first,&p.second);
            if(str[0]=='a')
                s.insert(p);
            else if(str[0]=='r')
                s.erase(p);
            else if(str[0]=='f'){
                set< pair<int,int> >::iterator it;
                it=s.lower_bound(p);
                for(;it!=s.end();it++)
                {
                    if(it->first > p.first && it->second > p.second)
                    {
                        cout<<it->first <<" " << it->second <<endl;
                        break;
                    }
                }
                if(it==s.end()) cout<<-1<<endl;
            }
            
        }
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值