ZOJ 1409 Communication System

本文介绍了一种特殊通信系统的最优设计方法,目标是在多种设备及不同制造商提供的选项中选取最佳组合,以实现最大化的性价比。通过枚举所有可能的带宽值,并针对每个带宽值选择最低价格的设备来达到整体系统性能最优。
摘要由CSDN通过智能技术生成
Communication System

Time Limit: 10 Seconds       Memory Limit: 32768 KB

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.

By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.


Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 <= n <= 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 <= i <= n) starts with mi (1 <= mi <= 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.


Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.


Sample Input

1
3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110


Sample Output

0.649


题意:有n种设备,每种有mi件,每件设备有一个带宽和价格,从每种设备中选一件,使得带宽B/总价格P的值最大。B为挑选的n件设备中带宽最小的设备的带宽,P为n件设备的总价格。
分析:要求最大的带宽价值比,只需让带宽尽可能的大,总价格尽可能的小就行。所以可以枚举所有可能的带宽,然后从选出n件设备,每种设备贪心选择满足带宽限制的价格最小的,这样能保证总价格最小。
#include <cstdio>
#include <set>
#include <algorithm>
using namespace std;
const int maxn  = 100 + 10;

set<int> s;     //保存所有可能的带宽
set<int> :: iterator it;
int t, n, m;
int b[maxn][maxn], p[maxn][maxn];

int main()
{
    scanf("%d", &t);
    while (t--){
        scanf("%d", &n);
        s.clear();
        for (int i = 0; i < n; i++){
            scanf("%d", &m);
            for (int j = 0; j < m; j++){
                scanf("%d%d", &b[i][j], &p[i][j]);
                s.insert(b[i][j]);
            }
        }
        double ans = 0;
        for (it = s.begin(); it != s.end(); it++){     //枚举带宽
            int k = *it, sum = 0;
            for (int i = 0; i < n; i++){    //枚举第i种设备
                int min1 = 0x3fffff;
                for (int j = 0; j < m; j++){     //枚举第j件
                    if (b[i][j] >= k && p[i][j] < min1)    //挑选满足条件的价格最小的 
                        min1 = p[i][j];
                }
                sum += min1;
            }
            if (k * 1.0 / sum > ans)
                ans = k * 1.0 / sum;
        }
        printf("%.3lf\n", ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值