Guilty Prince

E - BFS
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Once there was a king named Akbar. He had a son named Shahjahan. For an unforgivable reason the king wanted him to leave the kingdom. Since he loved his son he decided his son would be banished in a new place. The prince became sad, but he followed his father's will. In the way he found that the place was a combination of land and water. Since he didn't know how to swim, he was only able to move on the land. He didn't know how many places might be his destination. So, he asked your help.

For simplicity, you can consider the place as a rectangular grid consisting of some cells. A cell can be a land or can contain water. Each time the prince can move to a new cell from his current position if they share a side.

Now write a program to find the number of cells (unit land) he could reach including the cell he was living.

Input

Input starts with an integer T (≤ 500), denoting the number of test cases.

Each case starts with a line containing two positive integers W and HW and H are the numbers of cells in the x and y directions, respectively. W andH are not more than 20.

There will be H more lines in the data set, each of which includes W characters. Each character represents the status of a cell as follows.

1) '.' - land

2) '#' - water

3) '@' - initial position of prince (appears exactly once in a dataset)

Output

For each case, print the case number and the number of cells he can reach from the initial position (including it).

Sample Input

4

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

Sample Output

Case 1: 45

Case 2: 59

Case 3: 6

Case 4: 13


ps:广搜

代码:

#include<iostream>
#include<string>
#include<queue>
using namespace std;

struct P
{
	int x;
	int y;
}p;

char map[21][21];
int dis[4][2] = { 0, 1, 1, 0, 0, -1, -1, 0 };
int w, h;
queue<P> ps;

void bfs()
{
	int c = 1;
	while (!ps.empty())
	{
		P a = ps.front();
		ps.pop();
		for (int i = 0; i < 4; ++i)
		{
			p.x = a.x + dis[i][0];
			p.y = a.y + dis[i][1];
			if (p.x >= 0 && p.x < h && p.y >= 0 && p.y < w && map[p.x][p.y] == '.')
			{
				c++;
				map[p.x][p.y] = '@';
				ps.push(p);
			}
		}
	}
	cout << c << endl;
}

int main()
{
	int t, d = 1;
	cin >> t;
	while (d <= t)
	{
		cin >> w >> h;
		for (int i = 0; i < h; ++i)
		{
			for (int j = 0; j < w; ++j)
			{
				cin >> map[i][j];
				if (map[i][j] == '@')
				{
					p.x = i;
					p.y = j;
					ps.push(p);
				}
			}
		}
		cout << "Case " << d << ": ";
		bfs();
		d++;
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值