HDU5437 Alisha’s Party (优先队列 + 模拟)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2650    Accepted Submission(s): 722


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

 

Input
The first line of the input gives the number of test cases, T , where 1T15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000. The door would open m times before all Alisha’s friends arrive where 0mk. Alisha will have q queries where 1q100.

The ith of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1vi108, separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000.
 

 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

 

Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

 

Sample Output
Sorey Lailah Rose
 

 

Source
题意:有k个人来,门先会开m次,每次开门的条件是假设当第a个人来时,可以放b个人进来。最后会把人全部放进来。查询第i个进来的是谁?
收获:题目没有说开门条件第a个人是按从小到大排序的,而且也没说a一定大于b;所以要考虑这种情况,保持程序的健壮性。
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstdlib>
#include<string>
#include<map>
#include<stack>

using namespace std;
#define ll long long
#define lson le,mid,num<<1
#define rson mid+1,ri,num<<1|1
#define stop1 puts("QAQ")
#define stop2 system("pause")
#define maxn 160000

struct node
{
    char s[203];
    int val;
    int id;
    bool operator < (const node & a) const
    {
        if(val!=a.val)
            return val < a.val;
        return id>a.id;
    }

}peo[maxn];
struct kk
{
    int x,y;
}tt[maxn];

int cmp(kk a, kk b)
{
    return a.x < b.x;
}
char ans[maxn][203];

int main()
{

    int T;
    scanf("%d",&T);
    while(T--)
    {

        int k,m,q;
        scanf("%d%d%d",&k,&m,&q);
        for(int i=1;i<=k;i++)
        {
            scanf("%s%d",peo[i].s,&peo[i].val);
            peo[i].id=i;
        }

       for(int i=1;i<=m;++i)
        scanf("%d%d",&tt[i].x,&tt[i].y);

        sort(tt+1, tt+m+1,cmp);
        priority_queue<node> Q;
        memset(ans, 0, sizeof ans);

        int sum=0,pos=1;
        for(int i=1;i<=m;i++)
        {

            for(int j = pos; j <=tt[i].x; j++)
            {
                Q.push(peo[j]);
                pos++;
            }
            for(int j=1;j<=tt[i].y;j++)
            {
                if(!Q.empty())
                {node temp = Q.top();
                Q.pop();
                sum++;
                strcpy(ans[sum],temp.s);
                }
                else
                    break;
            }
        }

        for(int i=pos;i<=k;i++)
        {
            Q.push(peo[i]);
        }
        while(!Q.empty())
        {
            node temp = Q.top();
            Q.pop();
            sum++;
            strcpy(ans[sum],temp.s);
        }

        int ss;
        for(int i=1;i<q;i++)
        {
            scanf("%d",&ss);
            printf("%s ",ans[ss]);
        }
        if(q!=0)
        {
            scanf("%d",&ss);
            printf("%s\n",ans[ss]);
        }

    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/ZP-Better/p/4817302.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值