Hrbeu 1039

题目链接:http://acm.hrbeu.edu.cn/index.php?act=problem&id=1039

Binomial Showdown

TimeLimit: 1 Second   MemoryLimit: 32 Megabyte

Totalsubmit: 2337   Accepted: 573  

Description

In how many ways can you choose k elements out of n elements, not taking order into account?

Write a program to compute this number.

Input

The input will contain one or more test cases.

Each test case consists of one line containing two integers n (n >= 1) and k (0 <= k <= n).

Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2^31.

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816

题目没有给定n的范围只说了结果在2^31范围之内,所以打表肯定不行,直接用了Java的BigInteger。

import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
    public static void main(String args[])
    {
        Scanner cin=new Scanner(System.in);
        while(cin.hasNext())
        {
            int n=cin.nextInt();
            int k=cin.nextInt();
            if(n==0&&k==0) break;
            int tmp=n-k;
            int tt;
            if(tmp<k) 
            {
                tt=tmp;
                tmp=k;
                k=tt;
            }
            BigInteger ans1=BigInteger.ONE;
            BigInteger ans2=BigInteger.ONE;
            BigInteger ans;
            for(int i=n-k+1;i<=n;i++)
            {
                ans1=ans1.multiply(BigInteger.valueOf(i));
            }
            for(int i=2;i<=k;i++)
            {
                ans2=ans2.multiply(BigInteger.valueOf(i));
            }
            ans=ans1.divide(ans2);
            System.out.println(ans);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值