poj 1679-The Unique MST

点击打开链接

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17364 Accepted: 6012

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!


这个题跟NYOJ 118题一样.在这就不在多说了,但是有一些细节需要说一下,这个题可能不是联通的,所以当用prim算最小生成树的时候如果出现了最小生成树的值为无穷大的时候,则函数直接返回,并且输出0,这点比较坑....

#include<stdio.h>
#include<string.h>
int map[510][510];
int max[510][510];
bool used[510];
int dis[510];
int father[510];
int v, e;

void prim(int *min_tree, int *second)
{
	memset(dis, 127, sizeof(dis));
	memset(max, 0, sizeof(max));
	memset(used, 0, sizeof(used));
	memset(father, 0, sizeof(father));
	int ans = 0;
	int i, j;
	dis[1] = 0;
	int min = 0x7fffffff, mark;
	for(j = 0; j < v; j++)
	{
		min = 0x7fffffff;
		for(i = 1; i <= v; i++)
		{
			if(!used[i])
			{
				if(dis[i] < min)
				{
					min = dis[i];
					mark = i;
				}
			}
		}
		used[mark] = 1;
		ans += min;		
		max[mark][father[mark]] = map[mark][father[mark]];
		max[father[mark]][mark] = map[mark][father[mark]];
		map[mark][father[mark]] = 0;
		map[father[mark]][mark] = 0;
		for(i = 1; i <= v; i++)
		{
			if(used[i] && i != mark)
			{
				max[mark][i] = max[father[mark]][i] > max[father[mark]][mark] ? max[father[mark]][i] : max[father[mark]][mark];
				max[i][mark] = max[mark][i];
			}
		}
		for(i = 1; i <= v; i++)
		{
			if(map[mark][i] && !used[i])
			{
				if(dis[i] > map[mark][i])
				{
					dis[i] = map[mark][i];
					father[i] = mark;
				}
			}
		}
	}
	if(ans > 2000000000)
		return;
	*min_tree = ans;
	int second_tree = 0x7fffffff;
	for(i = 1; i <= v; i++)
	{
		for(j = 1; j <= v; j++)
		{
			if(map[i][j])
			{
				if(second_tree > ans - max[i][j] + map[i][j])
				{
					second_tree = ans - max[i][j] + map[i][j];
				}
			}
		}
	}
	*second = second_tree;
}
int main()
{
//	freopen("in.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while(t--)
	{
		memset(map, 0, sizeof(map));
		scanf("%d%d", &v, &e);
		int a, b, l;
		int i;
		for(i = 0; i < e; i++)
		{
			scanf("%d%d%d", &a, &b, &l);
			map[a][b] = l;
			map[b][a] = l;
		}
		a = 0;
		b = 1;
		prim(&a, &b);
		
		if(a == b)
			printf("Not Unique!\n");
		else
			printf("%d\n", a);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值