HDU2457--DNA repair


Problem Description
Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

Input
The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following N lines gives N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

Sample Input
  
  
2 AAA AAG AAAG 2 A TG TGAATG 4 A G C T AGT 0

Sample Output
  
  
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1200
#define inf 0x3f3f3f3f
int first,rear,Cnt;
int dp[1080][1080];
char str[28],ans[1080];
inline int min(int a,int b)
{
	return a>b?b:a;
}
struct node
{
	node * fail;
	node * next[4];
	int end,cnt;
	node()
	{
		end = 0;
		cnt = Cnt++;
		for(int i = 0;i < 4;i++)
		{
			next[i] = NULL;
		}
	}
}*q[maxn],*qq[maxn];

int getid(char a)
{
	switch(a)
	{
		case('A'):return 0;
		case('G'):return 1;
		case('C'):return 2;
		case('T'):return 3;
	}
}

void insert(char * s,node * root)
{
	node * p = root;
	int len = strlen(s);
	for(int i = 0 ;i < len;i++)
	{
		int id = getid(s[i]);
		if(p -> next[id] == NULL)
		{
			p -> next[id] = qq[Cnt-1] = new node();
		}
		p = p -> next[id];
	}
	p -> end = 1;
}

void build_ac_automation(node * root)
{
	q[rear++] = root;
	node * p = NULL;
	while(first < rear)
	{
		p = q[first++];
		for(int i = 0;i < 4;i++)
		{
			if(p -> next[i] != NULL)
			{
				if(p == root)
				{
					p -> next[i] -> fail = root;
				}
				else 
				{
					p -> next[i] -> fail = p -> fail -> next[i];
					if(p -> fail -> next[i] -> end)
					{
						p -> next[i] -> end = 1;
					}
				}
				q[rear++] = p -> next[i];
			}
			else 
			{
				if(p == root)
				{
					p -> next[i] = root;
				}
				else 
				{
					p -> next[i] = p -> fail -> next[i];
				}
			}
		}
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n,cas = 0;
	while(scanf("%d",&n)!=EOF && n)
	{
		cas++;
		first = rear = Cnt = 0;
		node * root;
		qq[0] = root = new node();
		for(int i = 0;i < n;i++)
		{
			scanf("%s",str);
			insert(str,root);
		}
		build_ac_automation(root);
		scanf("%s",ans);
		memset(dp,0x3f,sizeof(dp));
		dp[0][0] = 0;
		int len = strlen(ans);
		for(int i = 0;i < len;i++)
		{
			for(int j = 0;j < Cnt;j++)
			{
				if(dp[i][j] == inf)	continue;
				for(int k = 0;k < 4;k++)
				{
					if(qq[j] -> next[k] -> end)	continue;
					dp[i+1][qq[j]-> next[k] -> cnt] = min(dp[i][j] + (getid(ans[i]) != k),dp[i+1][qq[j] -> next[k] -> cnt]);
				}
			}
		}
		int Ans = inf;
		for(int i = 0;i < Cnt;i++)
		{
			Ans = min(Ans,dp[len][i]);
		}
		printf("Case %d: %d\n",cas,Ans == inf?-1:Ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值