HDU1007--最小点对

Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 

Author
CHEN, Yue
#include <iostream>  
#include <algorithm>  
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;  
const int SIZE = 100005;  
const int L = -1;  
const int R = 1;  
  
 typedef struct   
{  
    int index;    
    double x;  
    double y;    
}coord;  
  
coord num[SIZE], c[SIZE];  
  
double getDistance(coord &bi1, coord &bi2)    
{  
    return sqrt(pow(bi1.x - bi2.x, 2.0) + pow(bi1.y - bi2.y, 2.0));  
}  
  
bool cmpx(coord &bi1, coord &bi2)  
{  
    if (bi1.x == bi1.x)  
        return bi1.y < bi2.y;  
    else  
    return bi1.x < bi2.x;  
}  
  
bool cmpy(coord &bi1, coord &bi2)  
{  
    if (bi1.y == bi2.y)  
        return bi1.x < bi2.x;  
    else  
        return bi1.y < bi2.y;  
}  
  
inline double min(double &bi1, double &bi2, double &bi3)  
{  
    double minLength;  
    minLength = bi1 > bi2 ? bi2 : bi1;  
    minLength = minLength > bi3 ? bi3 : minLength;  
    return minLength;  
}  
  
inline double minDist(double &bi1, double &bi2)  
{  
    if (bi1 > bi2)  
        return bi2;  
    return bi1;  
}  
  
  
double divide_conquer(int low, int high)   
{  
    double dis;  
    int count = high - low;  
    if (count == 0)  
    {  
        return 0;  
    }  
    else if (count == 1)   
    {  
        dis = getDistance(num[low], num[high]);  
    }  
    else if (count == 2)   
    {  
        double temp1, temp2, temp3;  
        temp1 = getDistance(num[low], num[low + 1]);  
        temp2 = getDistance(num[low + 1], num[high]);  
        temp3 = getDistance(num[low], num[high]);  
        dis = min(temp1, temp2, temp3);  
    }  
    else   
    {  
        double leftmin, rightmin, min;  
        int mid = (low + high) / 2;  
        int p = 0;  
        int i, j;  
  
        leftmin = divide_conquer(low, mid);  
        rightmin = divide_conquer(mid + 1, high);  
        dis = minDist(leftmin, rightmin);  
  
         
        for (i = low; i <= mid; i++)  
        {  
            double leftCoord = num[mid].x - dis;  
            if (num[i].x >= leftCoord)  
            {  
                c[p].index = L;   
                c[p].x = num[i].x;  
                c[p].y = num[i].y;  
                p++;  
            }  
        }  
        for ( ; i <= high; i++)  
        {  
            double rightCoord = num[mid].x + dis;  
            if (num[i].x <= rightCoord)  
            {  
                c[p].index = R;   
                c[p].x = num[i].x;  
                c[p].y = num[i].y;  
                p++;  
            }  
        }  
        sort(c, c + p, cmpy);   
        for (i = 0; i < p; i++)  
        {  
            for (j = 1; (j <= 7) && (i + j < p); j++)  
            {     
                if (c[i].index != c[i + j].index)
                {  
                    min = getDistance(c[i], c[i + j]);  
                    if(min < dis)  
                    dis = min;  
                }  
            }  
        }  
    }  
    return dis;  
}  
  
  
int main ()  
{  
    int n;  
    while (cin >> n && n != 0)  
    {  
        double result = 0;  
          
        for (int i = 0; i < n; i++)  
        {  
            num[i].index = 0;  
            cin >> num[i].x >> num[i].y;  
        }  
  
        sort (num, num + n, cmpx);  
  
        result = divide_conquer(0, n - 1);  
  
        printf("%.2lf\n", result / 2);  
    }
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值