POJ2586--贪心

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.  
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.  

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
题意很简单,就是一年中,每5个月结一次账,1~5,2~6。。。。8~12都是亏的。
一个月如果赚,则赚s,如果亏,则亏d.
求是否盈利,利润最大值。此题应先根据s,d分类讨论,确定每5个月中至少有几个月
是亏钱的,才能满足5个月的总账是赤字。进而用贪心得思想,将亏的月份放在连续5个
月的尾部。
#include <iostream>
using namespace std;
int main()
{
	int s,d,sum;
	while(cin>>s>>d)
	{
		if(s>=4*d)
		{
			sum=-1;
		}
		if(3*d<=2*s&&s<4*d)
		{
			sum=3*s-9*d;
		}
		if(3*s>=2*d&&2*s<3*d)
		{
			sum=(s-d)*6;
		}
		if(3*s<2*d&&4*s>=d)
		{
			sum=(2*s-d)*4;
		}
		if(4*s<d)
		{
			sum=10*s-2*d;
		}
		if(sum>=0)
		{
			cout<<sum<<endl;
		}
		else cout<<"Deficit"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值