POJ 1328-Radar Installation(贪心)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 95531 Accepted: 21251

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

题意:给你n个岛屿,岛屿都在海上(x轴上方),然后让你在陆地上(x轴下方包括x轴)建雷达,使得所有

岛屿都能被检测到,问你雷达的最小数量是多少?

题解:我们可以以每个岛屿为圆心做圆,对于每个岛屿,假如存在能检测到的雷达,则与x轴会有两个交点(有可能相切,这时算一个),我们令开数组存一下对应两交点,然后就将问题转化为一维问题了,对b数组排序,然后从前到后扫一遍,对于当前岛屿

与陆地的交点,假如说没扫到,贪心思想是以该岛屿与陆地的右交点位置上建雷达,然后看后边的岛屿与陆地的左交点是否在该

雷达的左边,满足的话,则下一个岛屿不用再建雷达监测他了,很容易证明这个贪心思路一定是正确的,很好想。

#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 200005
typedef __int64 ll;
struct node
{
	double x,y;
}b[2005],a[2005];
bool comp(node a,node b)
{
	return a.y<b.y;
}
int main(void)
{
	int n,i,j,cases=0;
	double d,maxs;
	while(scanf("%d%lf",&n,&d)!=EOF)
	{
		if(n==0 && d==0)
			break;
		maxs=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&a[i].x,&a[i].y);
			maxs=max(maxs,a[i].y);
		}
		getchar();getchar();
		printf("Case %d: ",++cases);
		if(maxs>d || d<0)
		{
			printf("-1\n");
			continue;
		}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			double tmp=sqrt(d*d-a[i].y*a[i].y);
			b[i].x=a[i].x-tmp;
			b[i].y=a[i].x+tmp;
		}
		sort(b+1,b+n+1,comp);
		int p=1;
		double last=b[1].y;
		//for(i=1;i<=n;i++)
			//printf("%lf %lf\n",b[i].x,b[i].y);
		while(p<=n)
		{
			ans++;
			if(p==n)
				break;
			while(p<n && b[p].x<=last)
				p++;
			if(p==n && b[n].x<=last)
				break;
			last=b[p].y;
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值