POJ2488--A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
/*此题输出要按字典序。所以在深搜的时候有个小贪心。(注意看我的heng[] 和 zong[]数组)
  此题p和q的上限是26.我一直以为是8
  深搜的时候注意还原标记。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
bool vis[28][28];
bool flag=false;
int A[1000][4];
int p,q;
int heng[]={-1,1,-2,2,-2,2,-1,1};
int zong[]={-2,-2,-1,-1,1,1,2,2};
void dfs(int r,int c,int count)
{
	count++;
	A[count][1]=r;
	A[count][2]=c;
	if(count==p*q)
	{
		flag=true;
		for(int i=1;i<=p*q;i++)
		{
			int r=A[i][1];
			char c=A[i][2]+'A'-1;
			cout<<c<<r;
		}
		cout<<endl;
	}
	else
	{
		for(int i=0;i<8;i++)
		{
			int rr=r+heng[i];
			int cc=c+zong[i];
			if(((rr>=1&&rr<=p)&&(cc>=1&&cc<=q))&&((!vis[rr][cc])))
			{
				vis[rr][cc]=1;
				dfs(rr,cc,count);
				vis[rr][cc]=0;
				if(flag)
				{
					break;
				}
			}
		}
	}	
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		flag=false;
		scanf("%d%d",&p,&q);
		memset(vis,0,sizeof(vis));
		cout<<"Scenario #"<<i<<":"<<endl;
		for(int j=1;j<=p;j++)
		{
			for(int k=1;k<=q;k++)
			{
				memset(vis,0,sizeof(vis));
				vis[j][k]=1;
				dfs(j,k,0);
				if(flag) break;
			}
			if(flag) break;
		}
		if(!flag)
		cout<<"impossible"<<endl;
		if(i!=t) cout<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值