POJ3267--The Cow Lexicon

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
/*
单词有600个。给出的字符串长度上限300;
从后往前做。如果该字符能与单词的首字母匹配。那么就继续往下匹配看看。T表示文本串,用P表示单词。当T[i]!=P[j]的时候,就得匹配T[i+1]和P[j].以此类推,当最终是因为访问到T结束,则不删。如果是访问到P结束。那么就得进行比较。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
string A[608];
int dp[308];
inline int min(int a,int b)
{
	return a>b?b:a;
}
int main()
{
	int n,len;
	char T[308];
	while(scanf("%d%d",&n,&len)==2)
	{
		cin>>T;
		for(int i=1;i<=n;i++)
		{
			cin>>A[i];
		}
		sort(A,A+n);
		memset(dp,0,sizeof(dp));
		for(int i=len-1;i>=0;i--)
		{
			dp[i]=dp[i+1]+1;
			for(int j=1;j<=n;j++)
			{
				if(A[j][0]==T[i])
				{
					int len1=A[j].size();
					int m=i;
					for(int k=1;k<len1;k++)
					{
						m++;
						if(m>=len)break;
						while(T[m]!=A[j][k])
						{
							m++;
							if(m>=len)
							{
								break;
							}
						}
						if(m<len&&T[m]==A[j][k])
						{
							if(k==len1-1)
							{
								dp[i]=min(dp[i],dp[m+1]+m-i+1-len1);
							}
						}
					}
				}
			}
		}
		printf("%d\n",dp[0]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值